hdu-4883-TIANKENG’s restaurant

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 3071    Accepted Submission(s): 1136


Problem Description
TIANKENG manages a restaurant after graduating from ZCMU, and tens of thousands of customers come to have meal because of its delicious dishes. Today n groups of customers come to enjoy their meal, and there are Xi persons in the ith group in sum. Assuming that each customer can own only one chair. Now we know the arriving time STi and departure time EDi of each group. Could you help TIANKENG calculate the minimum chairs he needs to prepare so that every customer can take a seat when arriving the restaurant?
 

Input
The first line contains a positive integer T(T<=100), standing for T test cases in all.

Each cases has a positive integer n(1<=n<=10000), which means n groups of customer. Then following n lines, each line there is a positive integer Xi(1<=Xi<=100), referring to the sum of the number of the ith group people, and the arriving time STi and departure time Edi(the time format is hh:mm, 0<=hh<24, 0<=mm<60), Given that the arriving time must be earlier than the departure time.

Pay attention that when a group of people arrive at the restaurant as soon as a group of people leaves from the restaurant, then the arriving group can be arranged to take their seats if the seats are enough.
 

Output
For each test case, output the minimum number of chair that TIANKENG needs to prepare.
 

Sample Input
  
  
2 2 6 08:00 09:00 5 08:59 09:59 2 6 08:00 09:00 5 09:00 10:00
 

Sample Output
  
  
11 6

这道题充分暴露了自己有多水!

就是简单的暴力

开一个数组,给定一段时间,转化为分钟,在对应的区间加上相应的相应的人数

#include<stdio.h>
#include<string.h>
int time[1500];
struct //结构体两个开的有点多余,去掉换成普通变量就好
{
    int num;
    char b[10];
    char e[10];
} g[10010];
struct node
{
    int num;
    int bt;
    int et;
} gt[10010];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,max=0;
        scanf("%d",&n);
        memset(time,0,sizeof(time));
        for(int i=1; i<=n; i++)
        {
            scanf("%d%s%s",&g[i].num,g[i].b,g[i].e);
            gt[i].num=g[i].num;
            gt[i].bt=(g[i].b[0]-'0')*600+(g[i].b[1]-'0')*60+(g[i].b[3]-'0')*10+(g[i].b[4]-'0');//将char型转化为int
            gt[i].et=(g[i].e[0]-'0')*600+(g[i].e[1]-'0')*60+(g[i].e[3]-'0')*10+(g[i].e[4]-'0');//顺便把分钟算出来
            for(int j=gt[i].bt+1;j<=gt[i].et;j++)
            {
                time[j]+=gt[i].num;
            }
        }
        for(int i=0;i<=1445;i++)
        {
            if(time[i]>max)
            {
                max=time[i];
            }
        }
        printf("%d\n",max);
    }
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值