The Marshtomp has seen it all before

The Marshtomp has seen it all before
Time Limit:1000MS     Memory Limit:262144KB     64bit IO Format:%lld & %llu

Description

14184646038225.jpg

fjxmlhx不喜欢网上的 marshtomps 。所以他决定把所有的 “marshtomp”(名字不区分大小写) 改为 “fjxmlhx;

Input

输入包含多行,每行字符串不超过200的长度,一个单词不会一半出现在上一行,剩下的在下一行。直到文件结束(EOF)

Output

输出 替换之后的字符串。

Sample Input

The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB

Sample Output

The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB



简单题   dbug几个小时···········

教训

~~~~~

错误代码

#include<stdio.h>
#include<string.h>
char a[10000];
int main()
{


    while(gets(a))
    {
        int len;
        len=strlen(a);
        for(int i=0; i<len; i++)
        {
            if(a[i]=='m'||a[i]=='M')
            {
                if(a[i+1]=='a'||a[i+1]=='A')
                {
                    if(a[i+2]=='r'||a[i+2]=='R')
                    {
                        if(a[i+3]=='s'||a[i+3]=='S')
                        {
                            if(a[i+4]=='h'||a[i+4]=='H')
                            {
                                if(a[i+5]=='t'||a[i+5]=='T')
                                {
                                    if(a[i+6]=='o'||a[i+6]=='O')
                                    {
                                        if(a[i+7]=='m'||a[i+7]=='M')
                                        {
                                            if(a[i+8]=='p'||a[i+8]=='P')
                                            {
                                                i=i+8;
                                                printf("fjxmlhx");
                                            }
                                        }
                                    }
                                }
                            }
                        }
                    }
                }
            }
            else
            {
                printf("%c",a[i]);
            }
        }
        printf("\n");
    }
    return 0;
}


  


下面分析错误原因

如果只输入m由于先判断第一个if  进入if  可是后面的又不符合,于是下面的else也无法输出

m这个数相当于让吞了

肯定WA了


AC代码

#include <stdio.h>  
#include <string.h>   
int main()  
{  
    char a[10000];  
    int s;  
    while(gets(a))  
    {  
        for(int i=0; i<strlen(a); i++)  
        {  
            s=0;  
            if(a[i]=='m'||a[i]=='M') s++;  
            if(a[i+1]=='a'||a[i+1]=='A') s++;  
            if(a[i+2]=='r'||a[i+2]=='R') s++;  
            if(a[i+3]=='s'||a[i+3]=='S') s++;  
            if(a[i+4]=='h'||a[i+4]=='H') s++;  
            if(a[i+5]=='t'||a[i+5]=='T') s++;  
            if(a[i+6]=='o'||a[i+6]=='O') s++;  
            if(a[i+7]=='m'||a[i+7]=='M') s++;  
            if(a[i+8]=='p'||a[i+8]=='P') s++;  
            if(s==9)  
                printf("fjxmlhx"),i+=8;  
            else  
                printf("%c",a[i]);  
        }  
        printf("\n");  
    }  
    return 0;  
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值