VIII

 VIII
Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u

Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3


        
  

Hint

       
       
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

就是一个队列一直添加元素在某个时候问你第k大的元素是什么
定义一个优先队列存入k个元素如果有大的元素就让最小的出列然后再让那个入列
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
#include<cstdio>
#include<queue>
using namespace std;
struct node{
	int x;
	bool friend operator <(node a,node b){
		return a.x>b.x;//优先小的元素
	}
}a;
int n,k;
int main(){
	while(~scanf("%d %d",&n,&k)){
		priority_queue<node> cnt;
		char s[5];
		for(int i=0;i<n;i++){
			scanf("%s",s);
			if(s[0]=='I'){
				scanf("%d",&a.x);
				cnt.push(a);
				if(cnt.size()>k)//判断队列中的元素是否超过了k个
					cnt.pop();
			}
			else{
				a=cnt.top();
				printf("%d\n",a.x);
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值