1921: B
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 249 Solved: 22
SubmitStatusWeb BoardDescription
给定一个长度为n的数字序列a,从中选取一个长为m的子序列b满足 b[i]&b[i-1] ! = 0 (2 < = i < = m)
求最大的m。
Input
第一行输入一个整数t,代表有t组测试数据。
每组数据第一行输入一个整数n代表a序列的长度,接下来一行输入n个正整数表示ai(0 < i < = n)。
1<=t<=20,0<=n<=100000,0<=ai<=1e9。
Output
一个整数表示最大的m。
Sample Input
1
3
1 1 1
Sample Output
3HINT
Source
haut
SubmitStatusWeb Board
DP题方程 mark = max ( dp[i][j-1]+1 ,mark)
更新或者不更新的问题 用一维数组优化了
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;
int x[40];//存放以该二进制位结尾为1的最多的子序列个数
int n;
int main(){
int T; scanf("%d",&T);
while(T--){
scanf("%d",&n);
int ans=0;
int a;int mark=0;
memset(x,0,sizeof(x));
for(int i = 1; i <= n; i++){
scanf("%d",&a); int k=a;
int j=1; //位数
mark=0;
while(a){
if(a&1){
mark=max(mark,x[j]+1);//这个数的该点为1就要更新最长的长度
}
a>>=1;
j++;
}
j=1;
while(k){
if(k&1)
x[j]=mark;//让所有在这个位为1的也都更新
j++; k>>=1;
}
ans=max(mark,ans);//更新最长子序列长度
}
printf("%d\n",ans);
}
return 0;
}