ZOJ-1704-To The Max (前缀和)

原题
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
Sample Output
15
题意:
输入一个n*n的矩阵,输出矩阵中和最大的子矩阵的和。
题解:
利用前缀和记录每个点与(0,0)点之间的和,之后枚举所有的矩阵,利用前缀和计算即可。(更多细节见代码)
附上AC代码:

#include <iostream>

using namespace std;
int num[105][105];
int sum[105][105];
int n;
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
        {
            cin>>num[i][j];
            sum[i][j]=sum[i-1][j]+sum[i][j-1]-sum[i-1][j-1]+num[i][j];//计算每一个点前缀和
        }
        int ans=-1e8;
        for(int i=0;i<=n;i++)//枚举所有的矩阵
        {
            for(int j=0;j<=n;j++)
            {
                for(int k=1;k<=n;k++)
                {
                    for(int m=1;m<=n;m++)
                    {
                        if(k>i&&m>j)//要求(k,m)必须大于(i,j),减少不必要的计算
                        {
                            int res=sum[k][m]-sum[k][j]-sum[i][m]+sum[i][j];//计算子矩阵的和
                            if(res>ans)
                                ans=res;
                        }
                    }
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

欢迎评论!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值