POJ-2262-Goldbach`s Conjecture (素数)

原题链接:
Goldbach’s conjecture is one of the oldest unsolved problems in number theory and in all of mathematics. It states:
Every even integer, greater than 2, can be expressed as the sum of two primes [1].
Now your task is to check whether this conjecture holds for integers up to 107.
Input
Input starts with an integer T (≤ 300), denoting the number of test cases.
Each case starts with a line containing an integer n (4 ≤ n ≤ 107, n is even).
Output
For each case, print the case number and the number of ways you can express n as sum of two primes. To be more specific, we want to find the number of (a, b) where
(1) Both a and b are prime
(2) a + b = n
(3) a ≤ b
Sample Input
2
6
4
Sample Output
Case 1: 1
Case 2: 1
Note
An integer is said to be prime, if it is divisible by exactly two different integers. First few primes are 2, 3, 5, 7, 11, 13, …
题意:
输出t个测试样例,每一个都只含有一个n(4<=n<=107),找出n能否由两个素数相加得到,若是能找出有几种组合。输出这样的组合数。
题解:
数据范围很小,打一个素数表,依次判断两个加数是否都是素数即可。(注意不要有重复的:(2,3)(3,2)只算一种)
附上AC代码:

#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
int prime[700000];
bool vis[10000005];
int cnt=0;
void el(int n)//素数打表
{
    int m=sqrt(n+0.5);
    memset(vis,0,sizeof(vis));
    for(int i=2;i<=m;i++)
    {
        if(!vis[i])
        for(int j=i*i;j<=n;j+=i)
        {
            vis[j]=1;
        }
    }
    for(int i=2;i<=n;i++)
    {
        if(!vis[i])
            prime[cnt++]=i;
    }
}
int main()
{
    el(10000000);
    int t,n;
    scanf("%d",&t);
    for(int cas=1;cas<=t;cas++)
    {
        int sum=0;
        scanf("%d",&n);
        for(int i=0;i<cnt;i++)
        {
            if(prime[i]>n-prime[i])//若是prime超过了n的一半,则所有的可能都已经找到了,剩下的都是重复的
                break;
            if(!vis[n-prime[i]])//判断是否为素数
            {
                sum++;
            }
        }
        printf("Case %d: %d\n",cas,sum);
    }
    return 0;
}

欢迎评论!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值