kuangbin带你飞专题一(搜索)C - Catch That Cow

上题:

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
解题思路:
第一次看到这道题觉得是个深搜题(我也不知道为什么。。。)最后写了之后发现不行,因为数太大,vis数组会爆掉,最后用了深搜,深搜也要有限制的条件才可以过去,中间有个小插曲自己vis数组没有更新 。。我还一直以为是自己vis数组开的太小了。。。一直内存超限 ,,最后卡了小20分钟,发现是这个原因,,,无限羞耻。。上代码
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
bool vis[400006];
int s,e;
struct node
{
	int x;
	int stept;
};
queue<node>que;
int bfs()
{
	memset(vis,0,sizeof(vis));
	node next,now;
	now.x=s;
	now.stept=0;
	vis[s]=1;
	que.push(now);
	while(!que.empty())
	{
		now=que.front();
		que.pop();
		if(now.x==e)
		{
			return now.stept;
		}
		next.x=now.x+1;
		if(!vis[next.x]&&(next.x>=0&&next.x<=100022))
		{
			next.stept=now.stept+1;
			vis[next.x]=1;
			que.push(next);
		}
		
		next.x=now.x-1;
		if(!vis[next.x]&&(next.x>=0&&next.x<=100022))
		{
			vis[next.x]=1;
			next.stept=now.stept+1;
			que.push(next);
		}
		
		next.x=now.x*2;
		if(!vis[next.x]&&(next.x>=0&&next.x<=200055))
		{
			vis[next.x]=1;
			next.stept=now.stept+1;
			que.push(next);
		}
	}

}
int main()
{
	while(scanf("%d%d",&s,&e)!=EOF)
	{
		int ans=bfs();
		printf("%d\n",ans);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值