一道数论水题,数据比较小,所以直接枚举就可以过,,烦人的是这道题的输出格式,,,让我pr了好几次,,终于ac。。。。。题目:
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input
1 10 1 20 3 30 4 0 0
Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
#include <stdio.h>
int main()
{
int kk;
scanf("%d",&kk);
//printf("\n");
while(kk--)
{
int n,m,i;
for(i=1;;++i)
{
scanf("%d%d",&n,&m);
if(n+m==0)
{break;}
int count=0;
printf("Case %d: ",i);
for(int j=1;j<n;++j)
{
for(int z=j+1;z<n;++z)
{
if((j*j+z*z+m)%(j*z)==0)
count++;
}
}
printf("%d\n",count);
}
if(kk>0)
printf("\n");
}
return 0;
}