POJ 3268 dijkstra()正反矩阵

       dijkstra的裸题,正反矩阵各求一遍即可。。。题目:

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7988 Accepted: 3538

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10
ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
const int N=1010;
int nfarm,npath,pos;
int map1[N][N],map2[N][N],visted[N];
int dis1[N],dis2[N];
#define MAX 0x7fffffff
void dijkstra(int dis[N],int map[N][N]){
  memset(visted,0,sizeof(visted));
  for(int i=1;i<=nfarm;++i)
	  dis[i]=map[pos][i];
  dis[pos]=0;
  visted[pos]=1;
  int newpos=pos;
  for(int i=1;i<=nfarm;++i){
	  for(int j=1;j<=nfarm;++j){
		  if(!visted[j]&&map[newpos][j]!=MAX&&dis[newpos]+map[newpos][j]<dis[j]){
		    dis[j]=dis[newpos]+map[newpos][j];
		  }
	  }
	  int mmin=MAX;
	  for(int j=1;j<=nfarm;++j){
		  if(!visted[j]&&mmin>dis[j]){
		    mmin=dis[j];
			newpos=j;
		  }
	  }
	  visted[newpos]=1;
  }
}
int main(){
	//freopen("11.txt","r",stdin);
	while(~scanf("%d%d%d",&nfarm,&npath,&pos)){
	  int x,y,z;
	  for(int i=0;i<=nfarm;++i){
		  for(int j=0;j<=nfarm;++j){
		    map1[i][j]=MAX;
			map2[i][j]=MAX;
		  }
	  }
	  while(npath--){
	    scanf("%d%d%d",&x,&y,&z);
		map1[x][y]=z;
		map2[y][x]=z;
	  }
	  dijkstra(dis1,map1);
	  dijkstra(dis2,map2);
	  int mmax=0;
	 /* for(int i=1;i<=nfarm;++i){
	    printf("%d ",dis1[i]);
	  }*/
	  for(int i=1;i<=nfarm;++i){
	    if(dis1[i]+dis2[i]>mmax)
			mmax=dis1[i]+dis2[i];
	  }
	  printf("%d\n",mmax);
	}
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值