POJ 1176 dfs

      这道题真恶心,,写出来dfs后提交,,wa了,仔细看题,才发现还要对二进制升序排序后输出。我去,,真够麻烦的。接下来就是转化成字符串,然后在用字符串比较,最后输出。。。值得注意的是,如果按开关的次数大于4,则和c%4+4次的效果是一样的,题目:

Party Lamps
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3315 Accepted: 1127

Description

To brighten up the gala dinner of the IOI'98 we have a set of N coloured lamps numbered from 
1 to N. The lamps are connected to four buttons: 
button 1 -- when this button is pressed, all the lamps change their state: those that are ON are turned OFF and those that are OFF are turned ON. 
button 2 -- changes the state of all the odd numbered lamps. 
button 3 -- changes the state of all the even numbered lamps. 
button 4 -- changes the state of the lamps whose number is of the form 3K+1 (with K >= 0), i.e., 1,4,7,... 
There is a counter C which records the total number of button presses. 
When the party starts, all the lamps are ON and the counter C is set to zero. 

You are given the value of counter C and information on the final state of some of the lamps. Write a program to determine all the possible final configurations of the N lamps that are consistent with the given information, without repetitions.

Input

Your program is to read from standard input. The input contains four lines, describing the number N of lamps available, the number C of button presses, and the state of some of the lamps in the final configuration. 
The first line contains the number N and the second line the final value of counter C. The third line lists the lamp numbers you are informed to be ON in the final configuration, separated by one space and terminated by the integer -1. The fourth line lists the lamp numbers you are informed to be OFF in the final configuration, separated by one space and terminated by the integer -1. 

The parameters N and C are constrained by: 
10 <= N <= 100 
1 <= C <= 10000 
The number of lamps you are informed to be ON, in the final configuration, is less than or equal to 2.The number of lamps you are informed to be OFF, in the final configuration, is less than or equal to 2.

Output

Your program is to write to standard output. The output must contain all the possible final configurations (without repetitions) of all the lamps. There is at least one possible final configuration. Each possible configuration must be written on a different line. Each line has N characters, where the first character represents the state of lamp 1 and the last character represents the state of lamp N. A 0 (zero) stands for a lamp that is OFF, and a 1 (one) stands for a lamp that is ON. Configurations should be listed in binary ascending order.

Sample Input

10
1
-1
7 -1

Sample Output

0000000000
0101010101
0110110110
ac代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <string.h>
using namespace std;
int num[110];
int on[2],off[2];
int n,c,k,kk,total;//total记录的是结果共有多少,k记录的是最后开着的灯有几个,kk记录的是最后关着的灯有几个
struct ss{
  char ch[110];
}aa[1010];
void dfs(int x){
	if(x==c+1){
		int flag=1;
		for(int i=0;i<k;++i){
			if(num[on[i]]!=1){
			  flag=0;break;
			}
		}
		for(int i=0;i<kk;++i){
			if(num[off[i]]!=0){
			  flag=0;break;
			}
		}
		if(flag==1){
		  char str[105];
		  int newflag=1;
		  for(int i=1;i<=n;++i)
		  {str[i-1]='0'+num[i];}
		  str[n]='\0';
		  for(int i=0;i<total;++i){
			  if(strcmp(str,aa[i].ch)==0)
			  {flag=0;break;}
		  }
		  if(flag==1){
		  strcpy(aa[total].ch,str);
		  total++;
		  }
		  return;
		}
	}
	else{
		for(int i=1;i<=4;++i){
			if(i==1){
				for(int j=1;j<=n;++j){
				  num[j]=!num[j];
				}
				dfs(x+1);
				for(int j=1;j<=n;++j)
					num[j]=!num[j];
			}
			else if(i==2){
				for(int j=1;j<=n;++j){
				  if(j%2)
					  num[j]=!num[j];
				}
				dfs(x+1);
				for(int j=1;j<=n;++j)
					if(j%2)
						num[j]=!num[j];
			}
			else if(i==3){
				for(int j=1;j<=n;++j){
				  if(j%2==0)
					  num[j]=!num[j];
				}
				dfs(x+1);
				for(int j=1;j<=n;++j)
					if(j%2==0)
						num[j]=!num[j];
			}
			else{
				for(int j=1;j<=n;++j){
				  if((j-1)%3==0)
					  num[j]=!num[j];
				}
				dfs(x+1);
				for(int j=1;j<=n;++j)
					if((j-1)%3==0)
						num[j]=!num[j];
			}
		}
	}
}
int cmp(ss a,ss b){
	return strcmp(a.ch,b.ch)<0;
}
int main(){
	//freopen("11.txt","r",stdin);
	while(~scanf("%d%d",&n,&c)){
		if(c>4){
	      c=c%4+4;
		}
	  int x,y;
	  for(int i=1;i<=n;++i)
	  {num[i]=1;}
	  k=0,kk=0,total=0;
	  while(scanf("%d",&x)&&x!=-1){
	    on[k++]=x;
	  }
	  while(scanf("%d",&y)&&y!=-1)
		 off[kk++]=y;
	  dfs(1);
	  sort(aa,aa+total,cmp);//字符串排序
	  for(int i=0;i<total;++i)
		  printf("%s\n",aa[i].ch);
	}
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值