POJ 1703 Find them, Catch them 并查集

      这道题和A BUG'S LIFE 是一样的,只需要加一个关系判断即可。当询问时,若两个点个根节点相同,则这两个点的关系确定,所以只需要确定是否属于同一个帮派即可。若两个节点的根节点不同,说明这两个节点的关系不确定。题目:

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20242 Accepted: 5988

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.
ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
const int N=100005;
int father[N],rankk[N];
int n,m;
void init(){
	for(int i=1;i<=n;++i){
		father[i]=i;
		rankk[i]=0;
	}
}
int find(int x){
	int fx=father[x];
	if(x!=father[x]){
	  father[x]=find(father[x]);
	  rankk[x]=(rankk[fx]+rankk[x])%2;
	}
	return father[x];
}
void Union_Set(int x,int y){
	int rootx=find(x);
	int rooty=find(y);
	if(rootx!=rooty){
	  father[rooty]=rootx;
	  rankk[rooty]=((rankk[x]+1)%2+rankk[y])%2;
	}
}
int main(){
	freopen("1.txt","r",stdin);
	int numcase;
	scanf("%d",&numcase);
	while(numcase--){
	  scanf("%d%d",&n,&m);
	  int x,y;
	  char ss[2];
	  init();
	  while(m--){
	    scanf("%s",ss);
		if(ss[0]=='D'){
		  scanf("%d%d",&x,&y);
		  Union_Set(x,y);
		}
		else{
	     scanf("%d%d",&x,&y);
		 int rootx=find(x);
		 int rooty=find(y);
		 if(rootx!=rooty){
		   puts("Not sure yet.");
		 }
		 else{
		   if(rankk[x]==rankk[y])
			   puts("In the same gang.");
		   else
			   puts("In different gangs.");
		 }
		}
	  }
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值