hdu-1518 Square

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8922    Accepted Submission(s): 2903


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
i在不同地方定义有时也会产生不同的效果,甚至会让你wa,所以要注意每一点是很重要的
代码如下:
#include<stdio.h>
#include<string.h>
int sum,flag;
int stick[30];
int mark[30];
int n;              //刚开始将i定义为全局变量,以为下边就不用定义了 
void dfs(int side,int l,int k){ //这样应该很方便的的,但是这样却错了 
	int i;            //所以定义变量的时候位置也很重要 
	if(side==5){
		flag=1;
		 return;
	}
	if(l==sum){
		dfs(side+1,0,0);
		if(flag)
		return ;
	}
	for(i=k;i<n;i++){
		 if(!mark[i]&&l+stick[i]<=sum){
		 	mark[i]=1;
		 	dfs(side,stick[i]+l,i+1);
		 	if(flag)
		 	   return ;
		 	mark[i]=0;
		 }
	}
}
int main(){
	int t;
	scanf("%d",&t);
//	printf("%d\n",t);
	while(t--){
		int i;
	  sum=0;
		memset(stick,0,sizeof(stick));
		memset(mark,0,sizeof(mark));
		scanf("%d",&n);
		for(i=0;i<n;i++){
			scanf("%d",&stick[i]);
			sum+=stick[i];
		}
	//	printf("%d\n",sum);
		if(sum%4!=0){
			printf("no\n");
			continue;
		}
		sum/=4;
		for(i=0;i<n;i++)
		{
			if(stick[i]>sum)
			   break;
		}
		if(i!=n){
			printf("no\n");
			continue;
		}
		flag=0;
		dfs(1,0,0);
		if(flag)
		   printf("yes\n");
		else
		   printf("no\n");
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值