大数乘法

<span style="font-family: Arial, Helvetica, sans-serif; font-size: 18pt; background-color: rgb(255, 255, 255);">Description</span>

#include <iostream>
#include <string.h>
 using namespace std;

 void multiply(const char *a,const char *b); 

int main()
{
    //cout<<"hicjiajia"<<endl;
    
    string num1,num2;     // 初始状态用string来存储大数
    cout<<"现在,来两个大数吧! "<<endl;
    cin>>num1>>num2;
    
    const char *p1=num1.c_str();    // 将string转为 const char *
    const char *p2=num2.c_str();    // 将string转为 const char *
    multiply(p1,p2);
    
    system("pause");
    return 0;
} 

void multiply(const char *a,const char *b)
{
     int i,j,ca,cb,*s;
     ca=strlen(a);
     cb=strlen(b);
     s=(int *)malloc(sizeof(int)*(ca+cb));   //分配存储空间
     for (i=0;i<ca+cb;i++) s[i]=0;      // 每个元素赋初值0
     
     for (i=0;i<ca;i++)
         for (j=0;j<cb;j++)
             s[i+j+1]+=(a[i]-'0')*(b[j]-'0');
             
     for (i=ca+cb-1;i>=0;i--)        // 这里实现进位操作
         if (s[i]>=10)
         {
             s[i-1]+=s[i]/10; 
             s[i]%=10;
         }
     
     char *c=(char *)malloc((ca+cb)*sizeof(char));  //分配字符数组空间,因为它比int数组省!
     i=0;while(s[i]==0) i++;   // 跳过头部0元素
     for (j=0;i<ca+cb;i++,j++) c[j]=s[i]+'0';
     c[j]='\0';
     for (i=0;i<ca+cb;i++) cout<<c[i];
     cout<<endl; 
     free(s);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值