HDU1394 Minimum Inversion Number

题目链接:戳进去

Minimum Inversion Number

Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1698  1540  1542  1255  2795 
 

按照程序的思路画个图一看就知道,至于得到初始数列的逆序数之后,求其他排列的逆序数就是这个公式: sum = sum + ( n-1 - x[i] ) - x[i]  ,为什么在程序的注释中写得很清楚。
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=5555;
int sum[maxn<<2];
void PushUP(int rt)     //PushUP左儿子和右儿子的和
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    sum[rt]=0;
    if(l==r) return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void updata(int p,int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]++;
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m) updata(p,lson);
    else updata(p,rson);
    PushUP(rt);
}
int query(int L,int R,int l,int r,int rt)
{
    if(L<=l && r<=R)
        return sum[rt];
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m) ret+=query(L,R,lson);
    if(R>m) ret+=query(L,R,rson);
    return ret;
}
int x[maxn];
int main()
{
    int n;
    while(cin>>n)
    {
        build(0,n-1,1);
        int sum=0;
        for(int i(0);i<n;i++)   //得到初始数列的逆序数
        {
            cin>>x[i];
            sum+=query(x[i],n-1,0,n-1,1);
            updata(x[i],0,n-1,1);
        }
        int ret=sum;
        /*因为这n个数包含从0到n-1之间所有的数,比x[i]小的数有x[i]个,所以把x[i]移到最后
        会导致sum少了x[i]个元素,但是比x[i]大的数有n-1-x[i]个,所以加上(n-1-x[i]).*/
        for(int i(0);i<n;i++)
        {
            sum=sum+(n-1-x[i])-x[i];
            ret=min(ret,sum);
        }
        cout<<ret<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值