【java】二叉树重建

输入二叉树的后序遍历和中序遍历,输出它的先序遍历。

样例输入:

ACBFGED ABCDEFG

CDAB CBAD

样例输出:

DBACEGF

BCAD

import java.util.Scanner;
public class Main {
	public static StringBuffer str=new StringBuffer();
	public static void buildTree(String s1,String s2){
		if(s1.length()<=0)
			return;
		char c=s1.charAt(s1.length()-1);
		int index=s2.indexOf(c);
		str.append(c);
		buildTree(s1.substring(0,index),s2.substring(0,index));
		buildTree(s1.substring(index,s1.length()-1),s2.substring(index+1));
	}
	public static void main(String[] args){
		Scanner scanner = new Scanner(System.in);
		while(scanner.hasNext())
		{
			String s1=scanner.nextLine();
			String s2=scanner.nextLine();
			str.setLength(0);
			buildTree(s1,s2);
			System.out.println(str.toString());
		}
		scanner.close();
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值