(POJ - 2533)Longest Ordered Subsequence

(POJ - 2533)Longest Ordered Subsequence

       Time Limit: 2000MS       Memory Limit: 65536K
       Total Submissions: 54195     Accepted: 24230

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

题目大意:给一个数字串,求最长上升子序列。

思路:和求两个字母串的最长公共子序列类似,可以从dp角度考虑。
[http://blog.csdn.net/wozaipermanent/article/details/76943411 “求最长公共子序列”]
设f[i]表示前i个数字中以i字母结尾的最长上升子序列,易得状态转移方程为(其中数组a储存最先输入的数字序列):
f[i]=max{f[j]}+1(其中1<=j < i,且a[i]>a[j],初值为f[1]=1)。
显然答案是max{f[i]}(1<=i<=n)。

#include<cstdio>
using namespace std;

const int maxn=1005;
int a[maxn],f[maxn];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++) scanf("%d",a+i);
        f[1]=1;
        int ans=1;
        for(int i=2;i<=n;i++)
        {
            int Max=0;
            for(int j=1;j<i;j++)
                if(a[j]<a[i]&&Max<f[j]) Max=f[j];  
            f[i]=Max+1;
            if(ans<f[i]) ans=f[i];
        }
        printf("%d\n",ans); 
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值