(POJ - 2456 )Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15529 Accepted: 7441
Description
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).
His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input
Line 1: Two space-separated integers: N and C
Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
- Line 1: One integer: the largest minimum distance
Sample Input
5 3
1
2
8
4
9
Sample Output
3
Hint
OUTPUT DETAILS:
FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.
Huge input data,scanf is recommended.
题目大意:一条直线上有n个牛棚,牛棚的位置为xi,每个牛棚只能放一头牛。现有c头牛要放入牛棚,要是两头牛之间的距离尽可能大。
思路:先对牛棚位置进行排序,则两头牛之间的最小距离为1,最大距离为x[n-1]-x[0],然后在这个区间二分答案即可。
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=100005;
int a[maxn];
int n,c;
bool check(int x)
{
int cnt=1,tmp=a[0];
for(int i=0;i<n;i++)
{
if(a[i]-tmp>=x)
{
cnt++;
tmp=a[i];
}
}
if(cnt>=c) return true;//答案偏小了
else return false;
}
int main()
{
while(scanf("%d%d",&n,&c)!=EOF)
{
for(int i=0;i<n;i++) scanf("%d",a+i);
sort(a,a+n);
int lo=1,hi=a[n-1]-a[0],mid,ans;
while(lo<=hi)
{
mid=(lo+hi)>>1;
if(check(mid))
{
ans=mid;
lo=mid+1;
}
else hi=mid-1;
}
printf("%d\n",ans);
}
return 0;
}