ZOJ 1045 HangOver

HangOver

Time Limit: 2 Seconds       Memory Limit: 65536 KB

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.


Example input:

1.00
3.71
0.04
5.19
0.00


Example output:

3 card(s)
61 card(s)
1 card(s)
273 card(s)



题意就是计算1/2+1/3+...1/(1+n)

因为菜鸟刚入手,所以不知道题目可以输入一个,马上输出一个,所以我下面的代码定义了个数组,把所有的输入

先存下,再输出,后来修改代码,看代码2,修改后的。


代码1:

#include<stdio.h>
#define M 100


int card(double b)
{
    int i=2;
    double sum=1/2.0;
    while(sum<=b)
    {
        sum+=1.0/(++i);
    }
    return i-1;
}


int main(int argc, char* argv[])
{
    int i=0,j;
    double a[M];
    double c;
scanf("%lf",&c);
    while(c!=0.00){
if(c>=0.01&&c<=5.20)
               {
a[i++]=c;
scanf("%lf",&c);
}
               else
               {
printf("data error\n");
}
}
    
    for(j=0;j<i;j++)
    {
if(a[j]<=1/2.0)
            printf("1 card(s)\n");
else
        printf("%d card(s)\n",card(a[j]));
    }
return 0;
}


代码2:

#include<iostream>
using namespace std;
int main()
{
    
double target,num,sum;
    
while(cin>>target&&target!=0.00)
     {
         sum 
= 0.0f;
         num 
= 2;
        
while(sum<target)
         {
             sum 
+= 1.0/num;
             num
++;
         }
         cout
<<num-2<<" card(s)"<<endl;
     }
    
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值