HDU 1209 Clock

Clock

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2754    Accepted Submission(s): 845


Problem Description
There is an analog clock with two hands: an hour hand and a minute hand. The two hands form an angle. The angle is measured as the smallest angle between the two hands. The angle between the two hands has a measure that is greater than or equal to 0 and less than or equal to 180 degrees.

Given a sequence of five distinct times written in the format hh : mm , where hh are two digits representing full hours (00 <= hh <= 23) and mm are two digits representing minutes (00 <= mm <= 59) , you are to write a program that finds the median, that is, the third element of the sorted sequence of times in a nondecreasing order of their associated angles. Ties are broken in such a way that an earlier time precedes a later time.

For example, suppose you are given a sequence (06:05, 07:10, 03:00, 21:00, 12:55) of times. Because the sorted sequence is (12:55, 03:00, 21:00, 06:05, 07:10), you are to report 21:00.
 

Input
The input consists of T test cases. The number of test cases (T) is given on the first line of the input file. Each test case is given on a single line, which contains a sequence of five distinct times, where times are given in the format hh : mm and are separated by a single space.
 

Output
Print exactly one line for each test case. The line is to contain the median in the format hh : mm of the times given. The following shows sample input and output for three test cases.
 

Sample Input
  
  
3 00:00 01:00 02:00 03:00 04:00 06:05 07:10 03:00 21:00 12:55 11:05 12:05 13:05 14:05 15:05
 

Sample Output
  
  
02:00 21:00 14:05
 

Source
 

Recommend
mcqsmall
 

分析:时针一小时走30度,分针一分钟走6度,时针一分钟走0.5度,注意若角度相同,时间早的输出

代码:这里防止浮点误差,直接把度数乘以2计算

#include<stdio.h>
#include<math.h>
struct node{
    int h;
    int m;
    int angle;
}a[5];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int h,m,ang1,ang2,ang3;
        int i,j;
        for(i=0;i<5;i++)
        {
            scanf("%d:%d",&a[i].h,&a[i].m);
            ang1=(a[i].h)%12*60+a[i].m;
            ang2=(a[i].m)*12;
            ang3=(int)fabs(ang1-ang2);
            if(ang3>360)
                ang3=720-ang3;
            a[i].angle=ang3;
        }
        for(i=0;i<5;i++)
            for(j=i+1;j<5;j++)
            {
                if(a[i].angle>a[j].angle)
                {
                    node temp=a[i];
                    a[i]=a[j];
                    a[j]=temp;
                }
                else if(a[i].angle==a[j].angle)
                {
                    if(a[i].h>a[j].h)
                    {
                        node temp=a[i];
                        a[i]=a[j];
                        a[j]=temp;
                    }
                }
            }
            printf("%02d:%02d\n",a[2].h,a[2].m);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值