Who's in the Middle poj2388 vector 水题

Who's in the Middle
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 33021
Accepted: 19238

Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input

5
2
4
1
3
5

Sample Output

3

Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.


题意就是让我们找到一组数中找到一个数,使得比它大的数的个数与比它小的数的个数相等,思路还是比较好想的,首先排个序,然后直接输出中间那个数就行了,这里本来可以用数组,但我最近在学STL,就用了<vector>,其实用<set>更简单,因为前者在数据插入完成后是无序的,而后者是有序的,但也无妨,因为可以用sort()对<vector>进行快速排序。
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
	vector<int> milk;
	vector<int>::iterator it;
	int n,temp;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>temp;
		milk.push_back(temp);
	}
	sort(milk.begin(),milk.end());
	cout<<milk[n/2]<<endl;
	return 0;
}













评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值