A strange lift HDU 1548 queue BFS 简单 水题

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12908    Accepted Submission(s): 4977


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
  
  
5 1 5 3 3 1 2 5 0
 

Sample Output
  
  
3

题目大意:有一个只有上下按钮的电梯,每一层有一个参数m,在这一层只能向上或向下走m层,问从A层到达B层最少需要走几步。


很明显的一道求最短路径的问题,这里我们采用BFS广搜来解决,因为行走路线可以形成一个二叉树,每一步都有两种选择:上或者下。因此,BFS的那种层层搜索恰好能让我们找到满足题目条件的最短路径,因为每搜索一层就相当于走一步。

#include<iostream>
#include<memory.h>
#include<queue>
using namespace std;
int n,a,b,step[300];

void BFS(int *floor)
{
	queue<int> q;
	int t;
	q.push(a);
	step[a]=0;
	while(!q.empty())
	{
		t=q.front();
		q.pop();
		if(t==b)
		break;
		int next=t+floor[t];
		if(next>=1&&next<=n&&step[next]==0)
		{
			q.push(next);
			step[next]=step[t]+1;
		}
		next=t-floor[t];
		if(next>=1&&next<=n&&step[next]==0)
		{
			q.push(next);
			step[next]=step[t]+1;
		}
	}
	if(t!=b)
	step[b]=-1;
}


int main()
{
	int i;
	while(cin>>n,n)
	{
		int *floor=new int[n+1];
		cin>>a>>b;
		for(i=1;i<=n;i++)
		cin>>floor[i];
		memset(step,0,sizeof(step));
		BFS(floor);
		cout<<step[b]<<endl;
	}
	
	
	return 0;
}














  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值