HDU1241 Oil Deposits DFS

Oil DepositsTime Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input

    
    
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output

  
  
0 1 2 2

题目大意:问有多少个由@组成的连续区域,相邻的@在同一个区域,对角线也算。

要想完整的遍历一个区域,可以用DFS,可以在搜索的时候直接把一个区域的所有@都赋值为*,这样,下次再搜索的时候就不会重复了。

这道题虽然不难,但我依然错了好几次,最后竟然是变量冲突,所以大家在以后做题的时候设置变量一定要养成好习惯,别想到什么设置什么。

#include <iostream>
#include <cmath>
#include <stdio.h>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <iomanip>
#include <algorithm>
#include <memory.h>
#define MAX 110
using namespace std;
int r,c;
int Count;
int dirr[]={-1,-1,-1,0,1,1,1,0};
int dirc[]={-1,0,1,1,1,0,-1,-1};
char Map[MAX][MAX];

void dfs(int _r,int _c)
{
    int R,C;
    for(int i=0;i<8;i++)
    {
        R=_r+dirr[i];
        C=_c+dirc[i];
        if(R>=0&&R<r&&C>=0&&C<c&&Map[R][C]=='@')
        {
            Map[R][C]='*';
            dfs(R,C);
        }
    }
}

void show()
{
    for(int i=0;i<r;i++)
        cout<<Map[i]<<endl;;
}

int main()
{
    int i,j;
    while(cin>>r>>c,r&&c)
    {
        Count=0;
        for(i=0; i<r; i++)
        {
            cin>>Map[i];
        }

        for(i=0; i<r; i++)
        {
            for(j=0; j<c; j++)
            {
                if(Map[i][j]=='@')
                {
                    dfs(i,j);
                    Count++;
                }
            }
        }
        cout<<Count<<endl;

    }



    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值