HDU 3746 Cyclic Nacklace 利用 KMP的next数组求循环节

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4077    Accepted Submission(s): 1836


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
  
  
3 aaa abca abcde
 

Sample Output
  
  
0 2 5

题目大意:找出一个字符串中的循环节,并且计算出最少还需要多少个字符才能让字符串中的循环节的数量为整数且大于1。

分析:要计算循环节,就要利用KMP中的next数组,因为在KMP中失配的时候,总是返回上一个循环节,并且这个循环节是最短的,不过需要将next数组简单处理一下。

    1.计算出字符串最后一个字符的下一个字符的next

    2.如果next的值为-1,按照0来处理,或者直接计算出初值为0的next

例如,对于字符串abcabca,长度len=7,最后一个字符a的next值为3,其后面一个字符(将设与前面的任何字符都不相等)的next值为4,那么我们取next[len]=4


做好了这些准备工作,可以通过一个公式计算出最短循环节的长度

cyclic=len-next[len](next[len]!=0),如果next[len]==0,那么最短的循环节的长度就是len,当然,如果len%cyclic==0,说明正好有整数个循环节。

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

char ordi[100010];
int Next[100010];
int t,len;

void get_next()
{
    int j,k;
    j=0;
    k=-1;
    Next[0]=-1;
    while(j<len)
    {
        if(k==-1||ordi[j]==ordi[k])
        {
            k++;
            j++;
            Next[j]=k;
        }-
        else
        {
            k=Next[k];
        }
    }
}



void show()
{
	for(int i=0;i<=len;i++)
	{
		cout<<Next[i]<<' ';
	}
	cout<<endl;
}
int main()
{
    cin>>t;
    int cyclic;
    while(t--)
    {
        scanf("%s",ordi);
        len=strlen(ordi);
        //ordi[len]='@';
        get_next();
        if(Next[len]==-1)//最后一个next值可能为-1
            Next[len]=0;
        //show();
        cyclic=len-Next[len];
        if(Next[len]==0)
        {
            cout<<len<<endl;
        }
        else if(len%cyclic!=0)
        {
            cout<<cyclic-len%cyclic<<endl;
        }
        else
        {
            cout<<0<<endl;
        }
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值