HDU 2665 Kth number 划分树 第一弹

Kth number
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

Give you a sequence and ask you the kth big number of a inteval.
 

Input

The first line is the number of the test cases. 
For each test case, the first line contain two integer n and m (n, m <= 100000), indicates the number of integers in the sequence and the number of the quaere. 
The second line contains n integers, describe the sequence. 
Each of following m lines contains three integers s, t, k. 
[s, t] indicates the interval and k indicates the kth big number in interval [s, t]
 

Output

For each test case, output m lines. Each line contains the kth big number.
 

Sample Input

     
     
1 10 1 1 4 2 3 5 6 7 8 9 0 1 3 2
 

Sample Output

     
     
2
 

这两天POJ又不知道抽什么风,上也上不去。。。

题意:给出一个数列,问一个给定区间(l,r)中的第k大数

思路:划分树模板题

代码:(这里,我将划分树封装成一个结构体)


#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#define MAXN 100010
using namespace std;

struct PTree
{
    int tree[20][MAXN];
    int sorted[MAXN];
    int toleft[20][MAXN];

    void init()
    {
        memset(tree,0,sizeof(tree));
    }

    void sort_tree(int n)
    {
        sort(sorted+1,sorted+1+n);
    }

    void build(int l,int r,int dep)
    {
        if(l==r)
            return;
        int mid=(l+r)>>1;
        int same=mid-l+1;
        for(int i=l;i<=r;i++)
            if(tree[dep][i]<sorted[mid])
                same--;
        int lpos=l;
        int rpos=mid+1;
        for(int i=l;i<=r;i++)
        {
            if(tree[dep][i]<sorted[mid])
                tree[dep+1][lpos++]=tree[dep][i];
            else if(tree[dep][i]==sorted[mid]&&same>0)
            {
                tree[dep+1][lpos++]=tree[dep][i];
                same--;
            }
            else
                tree[dep+1][rpos++]=tree[dep][i];
            toleft[dep][i]=toleft[dep][l-1]+lpos-l;
        }
        build(l,mid,dep+1);
        build(mid+1,r,dep+1);
    }
    int query(int L,int R,int l,int r,int dep,int k)
    {
        if(l==r)
            return tree[dep][l];
        int mid=(L+R)>>1;
        int cnt=toleft[dep][r]-toleft[dep][l-1];
        if(cnt>=k)
        {
            int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
            int newr=newl+cnt-1;
            return query(L,mid,newl,newr,dep+1,k);
        }
        else
        {
            int newr=r+toleft[dep][R]-toleft[dep][r];
            int newl=newr-(r-l-cnt);
            return query(mid+1,R,newl,newr,dep+1,k-cnt);
        }
    }
};

PTree tree;

int main()
{
    int T;
    int n,m;
    int i,l,r,k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        tree.init();
        for(i=1;i<=n;i++)
        {
            scanf("%d",&tree.tree[0][i]);
            tree.sorted[i]=tree.tree[0][i];
        }
        tree.sort_tree(n);
        tree.build(1,n,0);
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&l,&r,&k);
            printf("%d\n",tree.query(1,n,l,r,0,k));
        }
    }

    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值