poj 2960 S-Nim Nim博弈变形 有限取法

本文介绍了Nim博弈的一种变形,即在原游戏中限制每次取石子的数量。尽管如此,问题仍可转化为SG函数问题。通过将每堆石子视为独立的Nim游戏,每个游戏的SG值反映了其胜负状态。最后,通过这些SG值的异或运算,我们可以确定整个游戏的解。此题被归类为模板题。
摘要由CSDN通过智能技术生成

A - S-Nim
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows: 


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads. 

  The players take turns chosing a heap and removing a positive number of beads from it. 

  The first player not able to make a move, loses. 


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move: 


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1). 

  If the xor-sum is 0, too bad, you will lose. 

  Otherwise, move such that the xor-sum becomes 0. This is always possible. 


It is quite easy to convince oneself that this works. Consider these facts: 

  The player that takes the last bead wins. 

  After the winning player's last move the xor-sum will be 0. 

  The xor-sum will change after every move. 


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input

Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output

For each position: If the described position is a winning position print a 'W'.If the described position is a losing position print an 'L'. Print a newline after each test case. 
 

Sample Input

     
     
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output

     
     
LWW WWL


        Nim博弈的一种变形,实际上题目中把Nim博弈整个描述了一遍,连解法都说了,只是在Nim博弈的基础上增加了每次取石子的个数受到限制,但是,我们依然可以将其转换为SG函数的问题,详情可以看这篇文章,总的来说,就是将n堆石子看成n个Nim游戏,针对每一个Nim游戏,SG值就反应了其结果,而n个游戏的和我们就可以用这n个SG值相异或得到,实际上这是一道模板题。


/***********************
功能:n堆石子,每一堆每次只能取固定的个数,给出一种局面,最最后谁会赢
参数:堆数以及每一堆的数量
返回值:输赢
***********************/

#include <iostream>
#include <stdio.h>
#include <string.h>
#define maxn 11000
using namespace std;

int sg[maxn];
bool Hash[maxn];
void sg_solve(int *s,int t,int range)   //range求解范围 S[]数组是可以每次取的值,t是s的长度。
{
    int i,j;
    memset(sg,0,sizeof(sg));
    for(i=1;i<=maxn;i++)
    {
        memset(Hash,0,sizeof(Hash));
        for(j=0;j<t;j++)
            if(i - s[j] >= 0)
                Hash[sg[i-s[j]]] = 1;
        for(j=0;j<=maxn;j++)
            if(!Hash[j])
                break;
        sg[i] = j;
    }
}

int main()
{
    int i,j;
    int k,m,l;
    int s[maxn],hi;
    int ans;
    char res[maxn];
    while(~scanf("%d",&k)&&k)
    {
            for(i=0;i<k;i++)
                scanf("%d",&s[i]);
            sg_solve(s,k,10005);
            scanf("%d",&m);

            for(j=0;j<m;j++)
            {
                    ans=0;
                    scanf("%d",&l);
                    for(i=0;i<l;i++)
                    {
                            scanf("%d",&hi);
                            ans^=sg[hi];
                    }
                    res[j]=ans==0?'L':'W';
            }
            for(i=0;i<m;i++)
                printf("%c",res[i]);
            printf("\n");
    }
    return 0;
}
/*****************************
输入:
2 2 5
3
2 5 12
3 2 4 7
4 2 3 7 12
5 1 2 3 4 5
3
2 5 12
3 2 4 7
4 2 3 7 12
0
输出:
LWW
WWL
*****************************/



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值