POJ 1584 Robots 最少边覆盖 二分图最大匹配

 
 
如果将机器人走过的路线视为一条边,那么这道题和POJ 2594如出一辙,任然是求最少路径覆盖问题,并且点仍然是可以重复走的,因此可以使用二分图最大匹配来做,下面说说思路。 首先保存所有节点信息,然后由于机器人只能向右走或者向下走,因此我们对任意两个点a、b进行比较,如果由a可以走到b,那么就建一条<a,b>有向边,然后对这个新建的图进行hungary即可,ans=n-hungary()。
Robots
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 4165Accepted: 1913

Description

Your company provides robots that can be used to pick up litter from fields after sporting events and concerts. Before robots are assigned to a job, an aerial photograph of the field is marked with a grid. Each location in the grid that contains garbage is marked. All robots begin in the Northwest corner and end their movement in the Southeast corner. A robot can only move in two directions, either to the East or South. Upon entering a cell that contains garbage, the robot will pick it up before proceeding. Once a robot reaches its destination at the Southeast corner it cannot be repositioned or reused. Since your expenses are directly proportional to the number of robots used for a particular job, you are interested in finding the minimum number of robots that can clean a given field. For example, consider the field map shown in Figure 1 with rows and columns numbered as shown and garbage locations marked with a 'G'. In this scheme, all robots will begin in location 1,1 and end in location 6, 7.
Figure 1 - A Field Map
Figure 2 below shows two possible solutions, the second of which is preferable since it uses two robots rather than three.
Figure 2 - Two Possible Solutions
Your task is to create a program that will determine the minimum number of robots needed to pick up all the garbage from a field.

Input

The input consists of one or more field maps followed by a line containing -1 -1 to signal the end of the input data. A field map consists of one or more lines, each containing one garbage location, followed by a line containing 0 0 to signal the end of the map. Each garbage location consists of two integers, the row and column, separated by a single space. The rows and columns are numbered as shown in Figure 1. The garbage locations will be given in row-major order. No single field map will have more than 24 rows and 24 columns. The sample input below shows an input file with two field maps. The first is the field map from Figure 1.

Output

The output will consist of a single line for each field map containing the minimum number of robots needed to clean the corresponding field.

Sample Input

1 2
1 4
2 4
2 6
4 4
4 7
6 6
0 0
1 1
2 2
4 4
0 0
-1 -1

Sample Output

2
1

Source

 
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

struct P
{
    int r,c;
};

const int MAXN=1010;
int uN,vN;
int g[MAXN][MAXN];
int linker[MAXN];
bool used[MAXN];
P gp[MAXN*MAXN];
int gn;


bool dfs(int u)
{
    for(int v=0;v<vN;v++)
    {
        if(g[u][v]&&!used[v])
        {
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v]))
            {
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res=0;
    memset(linker,-1,sizeof(linker));
    for(int u=0;u<uN;u++)
    {
        memset(used,false,sizeof(used));
        if(dfs(u))
            res++;
    }
    return res;
}

void init()
{
    uN=vN=0;
    memset(g,0,sizeof(g));
    gn=0;
}

void addpoint(int r,int c)
{
    gp[gn].r=r;
    gp[gn++].c=c;
}

bool cmp(P a,P b)
{
    if((b.c-a.c)>=0&&(b.r-a.r>=0))
        return true;
    else
        return false;

}


int main()
{
    int r,c;
    int ans;
    while(~scanf("%d%d",&r,&c))
    {
        if(r==-1&&c==-1)
            break;
        if(r==0&&c==0)
        {
            printf("0\n");
            continue;
        }
        init();
        addpoint(r-1,c-1);
        while(~scanf("%d%d",&r,&c))
        {
            if(r==0&&c==0)
                break;
            addpoint(r-1,c-1);
        }
        uN=vN=gn;

        for(int i=0;i<gn;i++)
        {
            for(int j=i+1;j<gn;j++)
            {
                if(cmp(gp[i],gp[j]))
                    g[i][j]=1;
                if(cmp(gp[j],gp[i]))
                    g[j][i]=1;
            }
        }
        ans=gn-hungary();
        printf("%d\n",ans);

    }
    return 0;
}
 

查看原文:http://colorfulshark.cn/wordpress/robots-999.html
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值