二维树状数组模板+POJ2155(矩阵)

模板:

void add(int x,int y,int val)
{
    while(y<=n)
    {
        int tmp=x;
        while(tmp<=n)
        {
            c[tmp][y]+=val;
            tmp+=tmp&-tmp;
        }
       y+=y&-y;
    }
}
int getsum(int x,int y)
{
    int sum=0;
    while(y>0)
    {
        int tmp=x;
        while(tmp>0)
        {
            sum+=c[tmp][y];
            tmp-=tmp&-tmp;
        }
        y-=y&-y;
    }
    return sum;
}

对一个矩阵块修改呢要改四个点,下图黄色点是要修改的区域的边界点,我们修改的四个点呢是酱色的外面的大的四个点,原点呢是由题意而定一般是(1,1),(x,y)到(1,1)所有点的和,也就是矩阵块。(图很丑,随便画的凑活着看哈哈),左上和右下是加val,左下和右上是减val.这样求和求出每个点的真正值就不会出错,类似差分数组,存的可以是两个数之间的差值。再累加就是原值,这也是树状数组可以实现区间修改的原理,区间查询也可以,网上很多看一下就懂了。



下面给出一道经典的二维数组应用:

poj2155

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 
Input
The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 
Output
For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 
Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1

题意:

对矩阵的某一块(矩形)进行取反,很多次取反,最后问现在某个点是0还是1,矩阵仅由0,1构成。

刚开始不知道怎么做,后来看出只有零一的话,不断加一,取反一次就加一,奇数呢证明还是1,偶数就是0,这样就可以用神奇的二维树状数组了,代码如下:

#include<stdio.h>
#include<string.h>
using namespace std;
int c[1002][1002];
int n,t;
void add(int x,int y,int val)
{
    while(y<=n)
    {
        int tmp=x;
        while(tmp<=n)
        {
            c[tmp][y]+=val;
            tmp+=tmp&-tmp;
        }
        y+=y&-y;
    }
}
int getsum(int x,int y)
{
    int sum=0;
    while(y>0)
    {
        int tmp=x;
        while(tmp>0)
        {
            sum+=c[tmp][y];
            tmp-=tmp&-tmp;
        }
        y-=y&-y;
    }
    return sum;
}
int main()
{
    int x, x1,x2,y1,y2,flag=0;
    scanf("%d",&x);
    while(x--)
    {
        memset(c,0,sizeof(c));
        if(flag)printf("\n");
        flag=1;
        scanf("%d%d",&n,&t);
        while(t--)
        {
            char a[3];
            scanf("%s",a);
            if(a[0]=='C')
            {

                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                add(x1,y1,1);
                add(x2+1,y1,1);
                add(x1,y2+1,1);
                add(x2+1,y2+1,1);
            }
            else
            {
                scanf("%d%d",&x1,&y1);
                printf("%d\n",getsum(x1,y1)%2);
            }
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值