humble numbers问题

3 篇文章 0 订阅


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
算法思想:
就是用2,3,5,7循环来求第i个humble[i],第i个humble[i]必定等于前i-1个数中其中一个数与{2,3,5,7}中其中最小的乘积.

注意:

1.在输出是st代表frist,nd代表second,rd代表third,th代表其他的数。

2.由输出的格式可以得到以11,12,13结尾的数是th表示。

3.在定义数组时要定义成long long humble[5842],如果定义int humble[5842]会越界。

代码如下:

#include <stdio.h>
#include <stdlib.h>
int prime[4]={2,3,5,7};
long long humble[5845]={0};//
int main()
{
    int n,i,j,k;
    humble[1]=1;
    for(i=2;i<=5842;i++)
    {
        humble[i]=2000000001;
        for(j=0;j<4;j++)
        {
            for(k=i-1;k>=1;k--)
            {
                if(humble[k]*prime[j]<=humble[i-1])
                    break;
                if(humble[k]*prime[j]<humble[i])
                    humble[i]=humble[k]*prime[j];
            }
        }
    }
    while(scanf("%d",&n)&&n)
    {
        if(n%10==1&&n%100!=11)
        {
          printf("The %dst humble number is %d.\n",n,humble[n]);
        }
        else if(n%10==2&&n%100!=12)
        {
          printf("The %dnd humble number is %d.\n",n,humble[n]);
        }
        else if(n%10==3&&n%100!=13)
        {
          printf("The %drd humble number is %d.\n",n,humble[n]);
        }
        else
        {
          printf("The %dth humble number is %d.\n",n,humble[n]);
        }






    }
    return 0;
}





































评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值