(简单) 状态压缩dp HOJ 2421 Hie with the Pie

Hie with the Pie

My Tags  (Edit)
Source : East Central North America 2006
Time limit : 1 secMemory limit : 64 M

Submitted : 104, Accepted : 65

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n+1 lines each containing n+1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8


题意:店主要从披萨开始送披萨,需要到达每个点至少一次,最后回到起点,问需要的时间最少是多少
思路:题目规模很小,只有10, 所以很有可能用状态压缩。我们用dp[s][j]表示目前去过的地点的状态为s,目前处于第j个地方所需要的最少时间。因为有些点可能能经过多次,而且w[i][j]不一定是最小的,可能w[i][k]+w[k][j]更小,于是我们想到状态转移需要一个中间状态过渡,所以方程式dp[to][k] = min(dp[s][j],dp[s][i]+w[i][j]+w[j][k]; 边界条件是dp[1][0] = 0 其他无穷大

代码:
#include<iostream>
#include<algorithm>
#include<map>
#include<cstdio>
using namespace std;

const int inf = 0xfffffff;
const int maxn = 1<<12;
int w[15][15];
int n;
int dp[maxn][15];


int main()
{
    while (scanf("%d",&n) , n)
    {
        for (int i = 0 ; i <= n ; ++i)
        {
            for (int j = 0 ; j <= n ; ++j)
            {
                scanf("%d",&w[i][j]);
            }
        }
        int max_state = 1<<(n+1);
        for (int i = 0 ; i < max_state ; ++i)
        {
            for (int j = 0 ; j <= n ; ++j)
            {
                dp[i][j] = inf;
            }
        }
        dp[1][0] = 0;
        for (int s = 0 ; s < max_state ; ++s)
        {
            for (int j = 0 ; j <= n ; ++j) if (s&(1<<j))
            {
                if (dp[s][j]==inf) continue;
                for (int k = 0 ; k <= n ; ++k)
                {
                    for (int l = 0 ; l <= n ; ++l)
                    {
                        int to = s;
                        if ((s&(1<<k))==0) to += 1<<k;
                        if ((s&(1<<l))==0) to += 1<<l;
                        dp[to][l] = min(dp[to][l],dp[s][j]+w[j][k]+w[k][l]);
                    }
                }
            }
        }
        int ans = dp[max_state-1][0];
        for (int j = 1 ; j <= n ; ++j)
            ans = min(ans,dp[max_state-1][j] + w[j][0]);
        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值