OpenJudge_P2421 Exchange Rates(DP)

总时间限制: 1000ms 内存限制: 65536kB
描述
Now that the Loonie is hovering about par with the Greenback, you have decided to use your $1000 entrance scholarship to engage in currency speculation. So you gaze into a crystal ball which predicts the closing exchange rate between Canadian and U.S. dollars for each of the next several days. On any given day, you can switch all of your money from Canadian to U.S. dollars, or vice versa, at the prevailing exchange rate, less a 3% commission, less any fraction of a cent.
Assuming your crystal ball is correct, what’s the maximum amount of money you can have, in Canadian dollars, when you’re done?

输入
The input contains a number of test cases, followed by a line containing 0. Each test case begins with 0 < d ≤ 365, the number of days that your crystal ball can predict. d lines follow, giving the price of a U.S. dollar in Canadian dollars, as a real number.

输出
For each test case, output a line giving the maximum amount of money, in Canadian dollars and cents, that it is possible to have at the end of the last prediction, assuming you may exchange money on any subset of the predicted days, in order.

样例输入
3
1.0500
0.9300
0.9900
2
1.0500
1.1000
0

样例输出
1001.60
1000.00

来源
Waterloo

英语蒟蒻qwq,题都读错了

#include<cstdio>
#include<iostream>
using namespace std;
#define BeiYuMax max
int ld,lg,d,g,n;double e;
//inline int BeiYuMax(int a,int b){return a>b?a:b;}
int main(){
    while(1){
        scanf("%d",&n);if(!n) break;ld=100000,lg=0,g=0,d=0;
        for(int i=1;i<=n;i++){
            scanf("%lf",&e);
            d=max(int(lg*e*0.97),ld);g=max(lg,int(ld/e*0.97));
            ld=d,lg=g;
        }
        printf("%.2lf\n",ld/100.0);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值