概率dp HDU 4336 Card Collector

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1980    Accepted Submission(s): 925
Special Judge


Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award. 

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.
 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks. 

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.
 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.
 

Sample Input
    
    
1 0.1 2 0.1 0.4
 

Sample Output
    
    
10.000 10.500
 

Source
 

Recommend
zhoujiaqi2010   |   We have carefully selected several similar problems for you:   4337  4331  4332  4333  4334 


题意:你想要收起N个不同的卡片,给出每一次获得某卡片的概率,然后要求要集齐所有卡片的期望次数。

思路:卡片种类最多20种,第一时间想到用状态压缩来表示卡片的获得情况,1代表已经有了,0代表还没有,我们用dp[s] 表示从s到集齐的期望步数,那么dp[s] = sigma(dp[t]*p[j])+sigma(dp[s]*p[j])+1;  然后我们只要分开状态不变的系数和状态转移的系数,那么就可以直接算出dp[s]

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;
#define eps 1e-9
const int maxn = 1<<21;
double p[22];
double f[maxn];
int n;

void init()
{
    memset(f,0,sizeof(f));
}

void input()
{
    for (int i = 0 ; i < n ; ++i) scanf("%lf",p+i);
}


void solve()
{
    double pp;
    for (int s = (1<<n)-2 ; s >= 0 ; --s)
    {
        pp = 0;
        for (int j = 0 ; j < n ; ++j) 
        {
            if (s&(1<<j)) continue;
            int t = s+(1<<j);
            f[s] += p[j]*f[t];
            pp += p[j];
        }
        f[s] = (f[s]+1)/pp;
    }
    printf("%lf\n",f[0]);
}

int main()
{
    while (scanf("%d",&n)==1)
    {
        init();
        input();
        solve();
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值