(intermediate) UVA 1455 Kingdom

There were n cities in an ancient kingdom. In the beginning of the kingdom, all cities were isolated. Kings ordered their subjects to construct roads connecting cities. A lot of roads were built with time. Every road was always constructed along the line segment between two cities. All cities are partitioned into disjoint components of cities by road-connectivity. A connected component of cities was called a state. A state consists of cities and roads connecting them.

A historical record tells a time sequence of road constructions in order. A road connecting two cities A and B doesn't intersect with other roads at a point except for A and B. Before construction, A and B may have belonged to the same state or different states. After construction, A and B would belong to a same state, i.e., two states would merge into a state if needed.

Prof. Kim, a historian, is concerned about the following question: How many states does a horizontal line (corresponding to the latitude of a specific place) pass by at a moment of the past? The figure below shows an example of a configuration of roads at some moment. A circle represents a city and a line segment represents a road between two cities. There are 3 states. A line with y = 4.5 passes by two states with total 8 cities and a line with y = 6.5 passes by one state with 5 cities.

\epsfbox{p4730.eps}

You are to write a program which handles the following two types of commands:


  • road A B

    A road between two cities A and B will be constructed. The road doesn't intersect with other roads at a point except for A and B. This is an informative command and your program does not need to respond.

  • line C

    This is a query. The program should output the number of states which a line y = C passes by and the total number of cities of them.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. The first line of each test case contains an integer n, the number of cities, where 1$ \le$n$ \le$100, 000. Each of the following n lines contains two integers x and y (0$ \le$x, y$ \le$1, 000, 000), where (x, y) represents the coordinate of a city. There is a single space between the integers. The cities are numbered from 0 to n - 1 in order. The next line contains an integer m, the number of commands, where 1$ \le$m$ \le$200, 000. Each of the following m lines contains a command, either ``road A B" or ``line C", where 0$ \le$A $ \neq$ B < n and C (0 < C < 1, 000, 000) is a real number of which the fractional part is always 0.5. There exists at most one road construction connecting a pair of cities and there exists at least one query per a test case.

Output

Your program is to write to standard output. Print exactly one line for a query through all test cases. The line should contain two integers which represent the number of states and the total number of cities of them respectively.

The following shows sample input and output for three test cases.

Sample Input

3 
10 
1 7 
5 7 
8 6 
3 5 
5 5 
2 3 
10 3 
7 2 
4 1 
11 1 
11 
road 0 1 
road 3 5 
line 6.5 
road 4 2 
road 3 8 
road 4 7 
road 6 9 
road 4 1 
road 2 7 
line 4.5 
line 6.5 
1 
100 100 
1 
line 100.5 
2 
10 10 
20 20 
2 
road 0 1 
line 15.5

Sample Output

0 0 
2 8 
1 5 
0 0 
1 2



#include<iostream>
#include<vector>
#include<cstring>
#include<string.h>
#include<queue>
#include<stdio.h>
using namespace std;
#define clr(a,x) memset(a,x,sizeof(a))
const int N = 100000+5;
const int maxy=1000000+1;
const int inf = 1e9;
int sz[N],p[N],r[N],l[N];
int n;
inline int lowbit(int x) { return x&(-x); }
int find(int x)
{
	if(x==p[x]) return x;
	return p[x]=find(p[x]);
}

int state[N*10],num[10*N];

void add(int ps,int x,int*arr)
{
	while(ps<=maxy) {
		arr[ps]+=x;
		ps+=lowbit(ps);
	}
}

int query(int ps,int*arr)
{
	int sum=0;
	while(ps>0) {
		sum+=arr[ps];
		ps-=lowbit(ps);
	}
	return sum;
}

void update(int rt,int a,int b)
{
	if(r[rt]<=l[rt]) return;
	//printf("%d %d\n",l[rt],r[rt]);
	add(r[rt],-a,num);
	add(l[rt],a,num);

	add(r[rt],-b,state);
	add(l[rt],b,state);
}

void update(int u,int v)
{
	int rtu=find(u),rtv=find(v);
	update(rtu,-sz[rtu],-1); update(rtv,-sz[rtv],-1);
	p[rtu]=rtv;
	sz[rtv]+=sz[rtu];
	r[rtv]=max(r[rtv],r[rtu]);
	l[rtv]=min(l[rtv],l[rtu]);
	update(rtv,sz[rtv],1);
}

void query(int x)
{
	printf("%d %d\n",query(x,state),query(x,num));
}

int main()
{
	int T; cin>>T;
	while(T--) {
		scanf("%d",&n);
		clr(state,0); clr(num,0);
		for(int i=0;i<n;++i) {
			int x,y; scanf("%d%d",&x,&y);
			++y;
			r[i]=l[i]=y;
			sz[i]=1; p[i]=i;
		}
		char oper[10];
		int Q; scanf("%d",&Q);
		while(Q--) {
			scanf("%s",oper);
			if(oper[0]=='r') {
				int x,y; scanf("%d%d",&x,&y);
				if(find(x)==find(y)) continue;
				update(x,y);
			} else {
				int x; scanf("%d.5",&x);
				++x;
				query(x);
			}
		//	for(int i=1;i<=12;++i) printf("%d: %d %d\n",i,query(i,state),query(i,num));
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值