HDU 4791 Alice's Print Service

Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1426    Accepted Submission(s): 341


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
 

Source


题意:就是要打印n张纸,已知打印超过s1,s2,s3,s4.....sn张纸的话,单价分别是p1,p2,p3....pn,问答打印多少张花费最小。


思路:记录后缀的最小si*pi,  首先二分到对应的张数位置....然后看多买能不能更省.. 记得用long long


代码:

<span style="font-size:18px;"><strong>#include <iostream>
#include <vector>
#include <algorithm>
#include <string.h>
#include <cstring>
#include <stdio.h>
#include <cmath>
#include <math.h>
#define rep(i,a,b) for(int i=(a);i<(b);++i)
#define rrep(i,b,a) for(int i = (b); i >= (a); --i)
#define clr(a,x) memset(a,(x),sizeof(a))
#define LL long long
#define eps 1e-10
using namespace std;
const int maxn = 100000 + 5;
int s[maxn],p[maxn];
LL mincost[maxn];

inline LL min(LL a, LL b) { return a < b ? a : b; }
inline LL max(LL a, LL b) { return a > b ? a : b; }
void read_int(int & x)
{
    char ch = getchar();
    while (ch < '0' || ch > '9') ch = getchar();
    x = ch - '0'; ch = getchar();
    while ('0' <= ch && ch <= '9') {
        x = 10 * x + ch - '0';
        ch = getchar();
    }
}

int n,m;
void input()
{
    scanf("%d%d",&n,&m);
    rep(i,1,n+1) {
     //   scanf("%d%d",s+i,p+i);
        read_int(s[i]); read_int(p[i]);
    }
    mincost[n] = (LL) s[n] * p[n];
    rrep(i,n-1,1) mincost[i] = min(mincost[i+1],(LL) s[i] * p[i]);
}

void solve()
{
    while (m--) {
        int q; read_int(q);//scanf("%d",&q);
        if (q >= s[n]) {
            printf("%I64d\n",(LL) p[n] * q);
            continue;
        }
        int i = upper_bound(s+1,s+1+n,q) - s - 1;
        LL ans = min((LL)p[i] * q, mincost[i+1]);
        printf("%I64d\n",ans);
    }
}

int main()
{
    #ifdef ACM
        freopen("in.txt", "r", stdin);
    #endif // ACM
    int T; cin >> T;
    while (T--) {
        input();
        solve();
    }
}</strong></span>




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值