HDU 4791 Alice’s Print Service

题目:

Alice’s Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1596    Accepted Submission(s): 380

Problem Description
Alice is providing print service, while the pricing doesn’t seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It’s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , …, s n, p n (0=s 1 < s 2< … < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ … ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1.. q m (0 ≤ q i ≤ 10 9 ) are the queries.
 

Output
For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.
 

Sample Input
  
  
1 2 3 0 20 100 10 0 99 100
 

Sample Output
  
  
0 1000 1000
 

代码:
#include "stdafx.h"
#include <iostream>
#include <vector>

using namespace std;

int  Pretreatment(vector<int> s,vector<int> p,vector<int> &pretre) //预处理函数
{
	pretre.push_back(0);
	int temp;
	for (int i = 1; i < s.size(); i++)
	{
		temp = (s[i] * p[i]) / p[i - 1];
		pretre.push_back(temp);
		pretre.push_back(s[i]);
	}
	return 0;
}

int main() 
{
	int T;//实验次数
	int n, m, temp, q;
	cin >> T;
	//cout << endl;
	cin >> n >> m;
	vector<int> s;//储存页数区间
	vector<int> p;//储存区间价格
	vector<int> pretre;

	for (int i = 0; i < n; i++)//初始化s,p
	{
		cin >> temp;
		s.push_back(temp);
		cin >> temp;
		p.push_back(temp);
	}

	Pretreatment(s, p, pretre);//预处理页数与价格

	temp = 0;
	int index = pretre.size();
	while (temp < m)   //对输入页数进行判断输出最优价格
	{
		cin >> q;
		if (q == 0)
		{
			cout << 0 << endl;
		}
		else if (q >= s[n - 1])
		{
			cout << q*p[n - 1] << endl;
		}
		else {
			for (int i = 0; i < index - 1; i++)
			{
				if (q > pretre[i] && q < pretre[i + 1])
				{
					if (i % 2 == 0)
					{
						cout << q*p[i] << endl;
						continue;
					}
					else {
						cout << s[i / 2 + 1] * p[i / 2 + 1] << endl;
						continue;
					}
				}
			}
		}
		temp++;
	}	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值