PAT 甲级 1017 Queueing at Bank(25 分)简洁的写出来

原题地址:PAT Adv 1017

原题正文:

1017 Queueing at Bank(25 分)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

题目说明:

 这道题的数据量并不是很大,在这里我的目标是用足够简洁的代码将这个这个问题解决。在这道题中我们需要频繁的查询最早空闲的窗口的空闲时间,故使用multiset来存储所有窗口的空闲时间,由于multiset会自排序,那么我们取最早空闲的窗口的空闲时间就会非常方便。

AC代码:

#include<bits/stdc++.h>
using namespace std;
struct person{
    int arrive,useTime;
    bool operator < (const person &a) const{return this->arrive<a.arrive;}
};
int main(){
    int n, k, h, m, s, arrive, useTime, sum=0;
    scanf("%d%d",&n,&k);
    vector<person> v;
    multiset<int> endtime;
    //initialize previous end time of all windows
    for(int i=0;i<k;i++)endtime.insert(28800);
    //read the arriving time and serving time of all customers in stochastic order
    while(n--){
        scanf("%d:%d:%d %d",&h,&m,&s,&useTime);
        arrive=h*3600+m*60+s;
        if(arrive<=61200){
            useTime=useTime<=60?useTime*60:3600;
            v.push_back({arrive,useTime});
        }
    }
    sort(v.begin(),v.end());                //sort according to arriving time
    for(int i=0;i<v.size();i++){
        int minendtime=*endtime.begin();    //find the smallest end time of all windows
        sum+=v[i].arrive<minendtime?minendtime-v[i].arrive:0;     //update total waiting time
        //update end time of all windows
        endtime.erase(endtime.begin());
        endtime.insert(max(minendtime,v[i].arrive)+v[i].useTime);
    }
    printf("%.1f",v.size()?1.0*sum/v.size()/60:0.0);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值