题目如下:
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input2 1 01 1 02Sample Output
0 1
题意主要是给了树的非叶结点及对应的子结点,求出树每层的叶结点数量。我一下子没想好用什么来处理,上网查阅了下资料,发现是用深度优先搜索(dfs)来做的,就顺便复习了下深度优先搜索。深度优先搜索类似于树的先根遍历,从图中某个顶点出发,访问该顶点,依次从v的未被访问的邻接点出发深度优先遍历图,直至所有和v有路径想通的顶点都被访问到,若此时图中尚有顶点未被访问, 则另选图中一个未曾被访问的顶点作起始点,重复上述过程,直到所有顶点都被访问到为止。
在这个题目中,可以先用一个vector数组来储存,每个非叶结点为数组的一个元素,非叶结点的孩子结点放到对应的vector中,然后进行深度优先搜索,每当发现某层中的一结点没有孩子结点,则将该层的叶子结点数+1,等遍历完成后依次输出即可,代码如下:
#include <iostream>
#include <vector>
using namespace std;
int leaf[100];
int maxdepth = -1;
vector<int> v[100];
void dfs(int index, int depth)
{
if (v[index].size() == 0) //空的index说明没有孩子,即为叶子节点,当前层数的叶子节点数目+1
{
leaf[depth]++;
if (depth > maxdepth)
maxdepth = depth;
return;
}
for (int i = 0;i < v[index].size();i++)
{
dfs(v[index][i], depth + 1);
}
}
int main()
{
int nodes, nonLeafNodes;
int number,ID,temp;
//获取所有输入
cin >> nodes >> nonLeafNodes;
for (int i = 0;i < nonLeafNodes;i++)
{
cin >> ID >> number;
for (int j = 0; j < number;j++)
{
cin >> temp;
v[ID].push_back(temp);
}
}
dfs(1, 0);
cout << leaf[0];
//输出
for (int i = 1;i <= maxdepth;i++)
cout << " " << leaf[i];
return 0;
}
提交后结果没有问题。