PAT1007. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

这题就是给定一个数列,求最大子列和的问题。做的思想就是如果当前子列和小于0,则任何后面的加上它都会变小,所以当当前子列和小于0时则舍弃这段,从下一个数字开始重新计算即可。这道一模一样的题目我做过,在博客里的文章中也有详解: 最大子列和相关算法
下面是我这次用的做法:
#include <iostream>
#include <vector>

using namespace std;

int main()
{
	int k,number;
	vector<int> v;
	int tempLeft, leftNum, rightNum, thisSum, maxSum;
	cin >> k;
	for (int i = 0;i < k;i++)
	{
		cin >> number;
		v.push_back(number);
	}

	tempLeft = leftNum = v[0];
	rightNum = v[k - 1];
	thisSum = maxSum = 0;   //如果所有都为负数,则最大和为0,左右的数字为开始和结束的数字,所以初始值这样设定。
	for (int i = 0;i < k;i++)
	{
		thisSum += v[i];
		if (thisSum > maxSum)     //如果当前和比最大和大则更新左右的数字以及最大和。
		{
			leftNum = tempLeft;
			rightNum = v[i];
			maxSum = thisSum;
		}
		else if (thisSum < 0)	//当前和小于0则对后面的子列和变大没有帮助,将左边的数字更新成下一个。
		{
			thisSum = 0;
			if (i + 1 < k)
			{
				tempLeft = v[i + 1];
			}
		}
		else if (v[i] == 0 && maxSum == 0)	//如果最大和还是0且当前数字为0,则将左右数字都设为0,这样区别开所有数字都小于0的情况
		{
			rightNum = 0;
			leftNum = 0;
		}
	
	}

	cout << maxSum << " " << leftNum << " " << rightNum;

	return 0;
}

一次通过所有用例。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值