PAT1013. Battle Over Cities (25)

题目如下:

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

刚看到这个题目,一下子不知道怎么下手,知道是图相关的题目,但数据结构还没复习到这。后查阅了网上的一些资料。理解了题意其实是一开始一个连通图,去掉其中一个点和这个点到别的点的边之后,求连通分图的数量,求出后减1 即为答案。用一个数组visited表示是否被访问过,然后深度优先搜索即可。每次遍历一个连通分量,最后算出连通分量的数目。代码如下:

#include <iostream>
#include <vector>
using namespace std;
int highways[1001][1001];	//用邻接矩阵表示城市之间的连通情况
bool visited[1001];	//是否被访问过
int N, M, K;
void dfs(int index)
{
	visited[index] = true;
	for (int i = 1; i < N + 1; i++)
	{
		if (highways[index][i] == 1 && !visited[i])
		{
			dfs(i);
		}
	}
}

int main()
{
	cin >> N >> M >> K;
	int city1, city2,city,count;
	for (int i = 0;i < M;i++)
	{
		cin >> city1 >> city2;
		highways[city1][city2] = 1;
		highways[city2][city1] = 1;
	}

	for (int i = 0; i < K;i++)
	{
		cin >> city;
		count = 0;
		fill(visited, visited + 1001, false);
		visited[city] = true;
		for (int j = 1; j < N + 1;j++)
		{
			if (!visited[j])
			{
				dfs(j);
				count++;
			}
		}
		cout << count - 1<< endl;
	}


	
	return 0;
}

一次通过用例。主要是对图还不熟悉,需要进行相关复习。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值