Unit Fraction Partition

A fraction whose numerator is 1 and whose denominator is a positive integer is called a unit fraction. A representation of a positive rational number p/q as the sum of finitely many unit fractions is called a partition of p/q into unit fractions. For example, 1/2 + 1/6 is a partition of 2/3 into unit fractions. The difference in the order of addition is disregarded. For example, we do not distinguish 1/6 + 1/2 from 1/2 + 1/6. 

For given four positive integers p, q, a, and n, count the number of partitions of p/q into unit fractions satisfying the following two conditions. 

The partition is the sum of at most n many unit fractions. 
The product of the denominators of the unit fractions in the partition is less than or equal to a. 
For example, if (p,q,a,n) = (2,3,120,3), you should report 4 since 


enumerates all of the valid partitions. 

Input

The input is a sequence of at most 200 data sets followed by a terminator. 

A data set is a line containing four positive integers p, q, a, and n satisfying p,q <= 800, a <= 12000 and n <= 7. The integers are separated by a space. 

The terminator is composed of just one line which contains four zeros separated by a space. It is not a part of the input data but a mark for the end of the input. 

Output

The output should be composed of lines each of which contains a single integer. No other characters should appear in the output. 

The output integer corresponding to a data set p, q, a, n should be the number of all partitions of p/q into at most n many unit fractions such that the product of the denominators of the unit fractions is less than or equal to a. 

Sample Input

2 3 120 3
2 3 300 3
2 3 299 3
2 3 12 3
2 3 12000 7
54 795 12000 7
2 3 300 1
2 1 200 5
2 4 54 2
0 0 0 0

Sample Output

4
7
6
2
42
1
0
9
3
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int num;
int p,q,a,n;
void dfs(int t,int pl,int tp,int tq,int fac)//tp 分子 tq分母  
{
    if(fac>a) return ;//分母乘积>a返回
    if(p*tq==q*tp&&tq!=0)
    {
        num++;
        return ;
    }
    if(pl>=n) return ;//分数的个数
    if(p*tq<q*tp) return ;
    int tx,ty;
    if(tq)
    {
        tx=tq+t*tp;
        ty=t*tq;
    }
    else tx=1,ty=t;
    if(fac*t<=a) dfs(t,pl+1,tx,ty,fac*t);
    if(t+1<=a&&fac*(t+1)<=a) dfs(t+1,pl,tp,tq,fac);
}
int main()
{
    while(cin>>p>>q>>a>>n)
    {
        if(p==0&&q==0&&a==0&&n==0)
            break;
        num=0;
        dfs(1,0,0,0,1);
        cout<<num<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值