[博弈论]Stone

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 367    Accepted Submission(s): 284


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.
 

Sample Input
  
  
1 1 30 3 10 2 0 0
 

Sample Output
  
  
Jiang Tang Jiang
 

Source
 

Recommend
liuyiding


一道比较简单的博弈论

相当于加数,加到N则输

首先分析必胜状态,显然n-1是必胜状态,其他必胜状态都是要向它转化的。

n-1-k ~ n-2是必输状态。

n-1-2k ~ n-2-k 是必胜状态。

……

观察发现

[n-1-pk-k , n-1-pk]这个区间,有k+1个元素,每个这种区间的最后一个元素,即对k+1取模等于1的这个元素对应的状态都是必胜态。


另外当1<n<=k的时候,显然是必胜态。而n=1是必败态。所以还需要特判。


#include <cstdio>

int main()
{
//    freopen("stone.in","r",stdin);
//    freopen("stone.out","w",stdout);

    while (1)
    {
        int n,k;
        scanf("%d%d",&n,&k);
        if (n == 0 && k == 0)
            break;
        if (n < k)
        {
            if (n == 1)
                printf("Jiang\n");
            else
                printf("Tang\n");
        }
        else
        {
            if (n % (k+1) == 1)
                printf("Jiang\n");
            else
                printf("Tang\n");
        }
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值