【二分】【自适应Simpson】Bridge

A suspension bridge suspends the roadway from huge main cables, which extend from one end of the bridge to the other. These cables rest on top of high towers and are secured at each end by anchorages. The towers enable the main cables to be draped over long distances.

Suppose that the maximum distance between two neighboring towers is D, and that the distance from the top of a tower to the roadway is H. Also suppose that the shape of a cable between any two neighboring towers is the same symmetric parabola (as shown in the figure). Now given B, the length of the bridge and L, the total length of the cables, you are asked to calculate the distance between the roadway and the lowest point of the cable, with minimum number of towers built (Assume that there are always two towers built at the two ends of a bridge).

\epsfbox{p3485.eps}

Input 

Standard input will contain multiple test cases. The first line of the input is a single integer T (1$ \le$T$ \le$10) which is the number of test cases. T test cases follow, each preceded by a single blank line.

For each test case, 4 positive integers are given on a single line.

D
- the maximum distance between two neighboring towers;
H
- the distance from the top of a tower to the roadway;
B
- the length of the bridge; and
L
- the total length of the cables.

It is guaranteed that B$ \le$L. The cable will always be above the roadway.

Output 

Results should be directed to standard output. Start each case with "Case #:" on a single line, where # is the case number starting from 1. Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.

For each test case, print the distance between the roadway and the lowest point of the cable, as is described in the problem. The value must be accurate up to two decimal places.

Sample Input 

2

20 101 400 4042

1 2 3 4

Sample Output 

Case 1:
1.00

Case 2:
1.60


写出抛物线方程,注意到弧长关于h单调递增,因此可以二分。列出弧长的计算公式,积分用自适应Simpson计算。

当每个抛物线的宽度最大时, 支柱个数最少。

注意比较的时候和L/n比较,因为L是总长度,而L/n才是抛物线的弧长。

二分出h,然后比较计算出来的弧长和要求的弧长,调整区间。


我把二分区间最小值设为10^-3,其实不太好,因为近似算法本身存在一定误差,而且近似出的结果和宽度的比较也有一定误差,所以最好把区间最小值设得更小一些。

小心最后不能多输回车。

#include <cstdio>
#include <cmath>

double a;
double h;
double D1,L1;

double f(double x)
{
	return sqrt(1.0+4.0*a*a*x*x);
}

double simpson(double a,double b)
{
	double c = a+(b-a)/2;
	return (f(a)+4*f(c)+f(b))*(b-a)/6;
}

double asr(double a,double b,double eps,double A)
{
	double c = a+(b-a)/2;
	double L = simpson(a,c) , R = simpson(c,b);
	if (fabs(L+R-A) <= 15*eps) return L+R+(L+R-A)/15.0;
	return asr(a,c,eps/2,L) + asr(c,b,eps/2,R);
}

double asr(double a,double b,double eps)
{
	return asr(a,b,eps,simpson(a,b));
}

double F(double w,double h)
{
	a = 4.0*h/(w*w);
	return 2*asr(0,w/2,1e-8);
}

double eps = 1e-8;

int main()
{
	freopen("3485.in","r",stdin);
	freopen("3485.out","w",stdout);

	int T;
	scanf("%d",&T);
	int D,H,B,L;
	int cases = 0;

	while (scanf("%d%d%d%d",&D,&H,&B,&L)!=EOF)
	{
		cases ++;
		double l = 0; double r = H;
		int n = (B+D-1)/D;
		D1 = double(B)/n;
		L1 = double(L)/n;
		while (r-l>1e-3)
		{
			h = (r+l)/2.0;
			double rs = F(D1,h);

			//printf("Debug F(%lf,%lf) = %lf\n",w,h,rs);
			if (rs < L1-eps)
				l = h;
			else
				r = h;
		}

		if (cases > 1) printf("\n");
		printf("Case %d:\n%.2lf\n",cases,H-h);
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值