[树状数组][离散化]Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 38472 Accepted: 13874

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


POJ2299

快速排序的交换次数,容易发现,就是逆序对的数目。

可以用离散化+树状数组来解决。类似于hash。在元素对应的位置标记为1。在线算法,通过统计[1,n]的1的数量,即可知道出现位置在i之前,且小于

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 38472 Accepted: 13874

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

POJ2299

快速排序的交换次数,容易发现,就是逆序对的数目。

可以用离散化+树状数组来解决。类似于hash。在元素对应的位置标记为1。在线算法,通过统计[1,n]的1的数量,即可知道出现位置在i之前,且小于a[i]的数的个数,剩余的即是逆序数。


离散化的处理使用另一个sort和unique处理之后的数组,通过lowerbound查找对应元素出现的位置即可实现离散化。


#include <cstdio>
#include <iostream>
using std::cout;
using std::cin;
#include <algorithm>
#include <cstring>
using namespace std;

int sorted[500010];
int num[500010];
int tree[500010];

#define lowbit(x) ((x)&(-(x)))


void insert(int i,int v,int n)
{
	while (i <= n)
	{
		tree[i] += v;
		i += lowbit(i);
	}

}

int query(int i)
{
	int ans = 0;
	while (i >= 1)
	{
		ans += tree[i];
		i -= lowbit(i);
	}
	return ans;
}

typedef long long ll;

int main()
{
	int n;
	while (scanf("%d",&n)!=EOF)
	{
		if (n == 0)
			break;
		memset(tree,0,sizeof tree);
		ll ans = 0;
		for (int i=1;i<=n;i++)
		{
			scanf("%d",num+i);
			sorted[i] = num[i];
		}
		sort(sorted+1,sorted+1+n);
		int len = unique(sorted+1,sorted+1+n)-sorted-1;
		//printf("Len = %d\n",len);
		for (int i=1;i<=n;i++)
		{
			num[i] = lower_bound(sorted+1,sorted+1+len,num[i])-sorted;
			//printf("%d ",num[i]);
		}
		//printf("\n");
		for (int i=1;i<=n;i++)
		{
	
			for (int j=0;j<n;j++)
			{
			//	printf("%d ",tree[j]);
			}
		
			//printf("\n");
			insert(num[i],1,n);
			int tmp = query(num[i]);
			//printf("Debug %d\n",tmp);
			ans += (ll)i-tmp;
		}
		cout << ans << endl;
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值