矩阵 Fibonacci

Fibonacci
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 

矩阵相乘+快速幂

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define ll __int64
#define mod 10000
using namespace std;
struct mat{
    int p[2][2];
};

mat fun(mat a, mat b){ //矩阵相乘
    int i, j, k;
    mat c;
    for(i=0; i<2; i++){
        for(j=0; j<2; j++){
            c.p[i][j] = 0;
            for(k=0; k<2; k++){
                c.p[i][j] += (a.p[i][k]%mod)*(b.p[k][j]%mod);
                c.p[i][j] % mod;
            }
        }
    }
    return c;
}

mat quick(mat a, ll n){ //快速幂 a^n
    mat b;
    int i, j, k;
    for(i=0; i<2; i++){
        for(j=0; j<2; j++){
            if(i==j)
                b.p[i][j] = 1;
            else
                b.p[i][j] = 0;
        }
    }
    while(n){
        if(n%2==1)
            b = fun(b,a);
        a = fun(a, a);
        n /= 2;
    }
    return b;
}
int main(){
    ll n;
    mat a;
    a.p[0][0] = 1;
    a.p[0][1] = 1;
    a.p[1][0] = 1;
    a.p[1][1] = 0;
    while(cin>>n){
        if(n==-1)
            break;
        mat x = quick(a,n); //a^n
        cout<<x.p[0][1]%mod<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值