hdu-1081 To The Max (最大子矩阵和)

http://acm.hdu.edu.cn/showproblem.php?pid=1081

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11309    Accepted Submission(s): 5454


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15

动态规划问题

可以将二维数组压缩成一维数组,求压缩后的数字最大子段和,即二维数组的最大子矩阵和。

将二维数组压缩:将第1行到第n行的每一列都加起来,即a[i][j]表示第j列前1-i行数的和,再求第i行最大子段和就可以了

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int main(){
    int n, a[110][110], i, j, k;
    while(cin>>n){
        memset(a, 0, sizeof(a));
        for(i=1; i<=n; i++){
            for(j=1; j<=n; j++){
                cin>>a[i][j];
                a[i][j] += a[i-1][j];//a[i][j]表示第j列前i行数的和
            }
        }
        int mmax = -1000000, sum;
        for(i=1; i<=n; i++){
            for(k=1; k<=i; k++){
                sum = 0;
                for(j=1; j<=n; j++){
                    sum += (a[i][j]-a[k-1][j]);
                    if(sum > mmax)
                        mmax = sum;
                    if(sum < 0)
                        sum = 0;
                }
            }
        }
        cout<<mmax<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值