RMQ with Shifts

Time Limit: 1000MS Memory Limit: 65535KB 64bit IO Format:

 Status

Description

In the traditional RMQ (Range Minimum Query) problem, we have a static array A. Then for each query (L, R) (L<=R), we report the minimum value among A[L], A[L+1], …, A[R]. Note that the indices start from 1, i.e. the left-most element is A[1].

In this problem, the array A is no longer static: we need to support another operation shift(i1, i2, i3, …, ik) (i1<i2<...<ik, k>1): we do a left “circular shift” of A[i1], A[i2], …, A[ik]. 

For example, if A={6, 2, 4, 8, 5, 1, 4}, then shift(2, 4, 5, 7) yields {6, 8, 4, 5, 4, 1, 2}. After that, shift(1,2) yields{8, 6, 4, 5, 4, 1, 2}.

Input

There will be only one test case, beginning with two integers n, q (1<=n<=100,000, 1<=q<=120,000), the number of integers in array A, and the number of operations. The next line contains n positive integers not greater than 100,000, the initial elements in array A. Each of the next q lines contains an operation. Each operation is formatted as a string having no more than 30 characters, with no space characters inside. All operations are guaranteed to be valid. Warning: The dataset is large, better to use faster I/O methods.

Output

For each query, print the minimum value (rather than index) in the requested range.

Sample Input

7 5 
6 2 4 8 5 1 4 
query(3,7) 
shift(2,4,5,7) 
query(1,4) 
shift(1,2) 
query(2,2)

Sample Output

1 
4 
6

线段树模板题


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[100010];
struct node{
    int l, r, mmin;
}t[100010*4];
void build(int i, int l, int r){
    t[i].l = l;
    t[i].r = r;
    if(l==r){
        t[i].mmin = a[l];
        return ;
    }
    int mid = (l+r)/2;
    build(i*2, l, mid);
    build(i*2+1, mid+1, r);
    t[i].mmin = min(t[i*2].mmin, t[i*2+1].mmin);
}
int query(int i, int x, int y){
    int l = t[i].l;
    int r = t[i].r;
    if(x==l&&y==r)
        return t[i].mmin;
    int mid = (l+r)/2;
    if(x>mid)
        return query(i*2+1, x, y);
    else if(y<=mid)
        return query(i*2, x, y);
    else
        return min(query(i*2, x, mid),query(i*2+1, mid+1, y));
}
void update(int i, int x, int y){
    int l = t[i].l;
    int r = t[i].r;
    if(l==x&&l==r){
        t[i].mmin = y;
        a[x] = y;
        return ;
    }
    int mid = (l+r)/2;
    if(x <= mid)
        update(i*2, x, y);
    else
        update(i*2+1, x, y);
    t[i].mmin = min(t[i*2].mmin, t[i*2+1].mmin);
}
int main(){
    int n, m, i, j, k, x, y, p, o;
    char ch[110];
    int b[110];
    while(~scanf("%d%d",&n,&m)){
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
           // getchar();
        build(1, 1, n);
        for(i=0; i<m; i++){
            scanf("%s",ch);
            int l = strlen(ch);
            o = 1;
            memset(b, 0, sizeof(b));
            if(ch[0]=='s'){
                for(j=0; j<l; j++){
                    p = 0;
                    if(ch[j]>='0'&&ch[j]<='9'){
                        for(k=j; k<l; k++){
                            if(ch[k]>='0'&&ch[k]<='9')
                                p = p*10+(ch[k]-'0');
                            else{
                                j = k;
                                break;
                            }
                        }
                    }
                    if(p!=0)
                        b[o++] = p;
                }
                int P = a[b[1]];
               // cout<<b[1]<<endl;
                for(k=1; k<=o-1; k++){
                    update(1, b[k], a[b[k+1]]);
                  //  a[b[k]] = a[b[k+1]];
//                  for(int pp=1; pp<=n; pp++)
//                    cout<<a[pp]<<" ";
//                  cout<<endl;
                }
                update(1, b[o-1], P);
              //  a[b[o-1]] = a[P];
            }
            else if(ch[0]=='q'){
                x = y = 0;
                int h;
                for(j=0; j<l; j++){
                    if(ch[j]=='(')
                        break;
                }
                for(h=j+1; h<l; h++){
                    if(ch[h]>='0'&&ch[h]<='9')
                        x = x*10+(ch[h]-'0');
                    else
                        break;
                }
                for(j=h+1; j<l; j++){
                    if(ch[j]>='0'&&ch[j]<='9')
                        y = y*10+(ch[j]-'0');
                    else
                        break;
                }
                printf("%d\n",query(1, x, y));
            }
           // getchar();
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值