POJ 2752--Seek the Name, Seek the Fame (next)

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7484 Accepted: 3520

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source



题意:求一个模式串中前缀与后缀相等的字串,输出这些字串的长度(递增)

思路:直接用KMP的next数组,求出后,从最后一个字符往前递归得到答案。


源代码:(282MS)

#include<iostream>
#include<string.h>
using namespace std;

const int MAX_LENGTH=400005;
int next[MAX_LENGTH];
char str[MAX_LENGTH];
int ans[MAX_LENGTH];

int main()
{
	int i,j;
	while(cin>>str+1)
	{
		int len=strlen(str+1);		//之前用str[0]来存长度,囧~~,忘了char类型才255
		//递归求next数组,初始化...
		i=1;	j=0;	next[1]=0;
		while(i<=len)//根据这题需要,最后一个字符的next[len+1]也要求出来
		{
			if(j==0 || str[i]==str[j]) {i++;  j++;  next[i]=j;}
			else j=next[j];
		}
		
		int cnt=0;
		ans[cnt++]=len;
		j=next[len+1];	//ans存答案,从最后一个字符的next[len+1]开始回溯
		while(j!=1)
		{
			ans[cnt++]=j-1;
			j=next[j];
		}
		for(--cnt;cnt>=0;cnt--)
			cout<<ans[cnt]<<" ";
		cout<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值