UVa 10290 {Sum+=i++} to Reach N (数论-整数和素数,组合数学-排列组合)

Problem H

{sum+=i++} to Reach N

Input: standard input

Output:  standard output

Memory Limit: 32 MB

 

All the positive numbers can be expressed as a sum of one, two or more consecutive positive integers. For example 9 can be expressed in three such ways, 2+3+44+5 or 9. Given an integer less than (9*10^14+1) or (9E14 + 1) or (9*1014 +1) you will have to determine in how many ways that number can be expressed as summation of consecutive numbers.

 

Input

The input file contains less than 1100 lines of input. Each line contains a single integer N  (0<=N<= 9E14). Input is terminated by end of file.

 

Output

For each line of input produce one line of output. This line contains an integer which tells in how many ways N can be expressed as summation of consecutive integers.

 

Sample Input

9

11

12

 

Sample Output

3

2

2


(Math Lovers’ Contest, Problem Setter: Shahriar Manzoor)


题目大意:

问一个数n,用连续的几个数相加表示的方案数。


解题思路:

假设首项为a,有m项,则 (a+a+m-1)*m=2*n。

当m为奇数,a+a+m-1必为偶数;当m为偶数,a+a+m-1必为奇数,所以为2n = 奇数×偶数。

需要将2n分解质因数,因奇数×奇数=奇数,所以求出2n的奇质因数的排列组合数,即所求方法数。


解题代码:

#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 3000010;
long long N, factorA[MAXN], factorB[MAXN], totFactor, prime[MAXN], totPrime, ans;
bool isPrime[MAXN];

void getPrime(int n) {
    memset(isPrime, true, sizeof(isPrime));
    totPrime = 0;
    for (int i = 2; i <= n; i++) {
        if (isPrime[i]) {
            prime[++totPrime] = i;
        }
        for (int j = 1; j <= totPrime && i*prime[j] <= n; j++) {
            isPrime[i*prime[j]] = false;
            if (i % prime[j] == 0) break;
        }
    }
}

void getFactor(long long n) {
    totFactor = 0;
    long long now = n;
    for (int i = 1; i <= totPrime && prime[i] <= now; i++) {
        if (now % prime[i] == 0) {
            factorA[++totFactor] = prime[i];
            factorB[totFactor] = 0;
            while (now % prime[i] == 0) {
                factorB[totFactor]++;
                now /= prime[i];
            }
        }
    }
    if (now != 1) {
        factorA[++totFactor] = now;
        factorB[totFactor] = 1;
    }
}

void solve() {
    while (N & 1 ==0 ) N >>= 1;
    getFactor(N);
    ans = 1;
    for (int i = 1; i <= totFactor; i++) {
        if (factorA[i] & 1 == 1) {
            ans *= factorB[i] + 1;
        }
    }
    cout << ans << endl;
}

int main() {
    ios::sync_with_stdio(false);
    getPrime(3000000);
    while (cin >> N) {
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值