HDU 4864 Task(基本算法-贪心)

Task

Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 

Sample Output
  
  
1 50004
 

Author
FZU
 

Source


题目大意:

有n台机器,m个任务,每台机器有xi,yi,每个任务也有xj,yj,任务j可以被机器i处理的条件是,xj<=xi 且 yj<yi,处理完产生 500*xj+2*yj 的价值,问你最多完成多少任务,在此基础上产生的最大价值是多少?


解题思路:

注意y的范围是 y<100,也就是x相差1,不管y相差多少,都不影响价值的关系。

贪心。机器和任务都按x排序,x相同按y排序。取排在最前的任务j,在所有xi大于yj的机器中,选取yi最小的与任务j匹配。(y较大的机器可以留给其他任务)


解题代码:
#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;

const int MAXN = 110;
struct Node {
    int x, y;
    bool operator<(const Node &b) const {
        if (x == b.x) {
            return y > b.y;
        } else {
            return x > b.x;
        }
    }
};
vector<Node> machine, task;
long long ans1, ans2;
int n, m, cnt[MAXN];

void init() {
    machine.clear();
    task.clear();
    memset(cnt, 0, sizeof(cnt));
    ans1 = ans2 = 0;
}

void input() {
    machine.resize(n);
    for (int i = 0; i < n; i++) {
        cin >> machine[i].x >> machine[i].y;
    }
    task.resize(m);
    for (int i = 0; i < m; i++) {
        cin >> task[i].x >> task[i].y;
    }
}

void work() {
    sort(task.begin(), task.end());
    sort(machine.begin(), machine.end());
    int index = -1;
    for (int i = 0; i < m; i++) {
        for (int j = index+1; j < n; j++) {
            if (machine[j].x >= task[i].x) {
                cnt[machine[j].y]++;
                index = j;
            } else {
                index = j - 1;
                break;
            }
        }
        for (int j = task[i].y; j <= 100; j++) {
            if (cnt[j]) {
                ans1++;
                ans2 += 500*task[i].x + 2*task[i].y;
                cnt[j]--;
                break;
            }
        }
    }
}

void output() {
    cout << ans1 << " " << ans2 << endl;
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> n >> m) {
        init();
        input();
        work();
        output();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值