HDU 5099 Comparison of Android versions(模拟-水题)

Comparison of Android versions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 226    Accepted Submission(s): 128


Problem Description
As an Android developer, itˇs really not easy to figure out a newer version of two kernels, because Android is updated so frequently and has many branches. Fortunately, Google identifies individual builds with a short build code, e.g. FRF85B.

The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat).
The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch.

The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010.

Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity.

Please develop a program to compare two Android build numbers.
 

Input
The first line is an integer n (1 <= n <= 2000), which indicates how many test cases need to process.

Each test case consists of a single line containing two build numbers, separated by a space character.
 

Output
For each test case, output a single line starting with ¨Case #: 〃 (# means the number of the test case). Then, output the result of release comparison as follows:

● Print "<" if the release of the first build number is lower than the second one;
● Print "=" if the release of the first build number is same as he second one;
● Print ">" if the release of the first build number is higher than the second one.

Continue to output the result of date comparison as follows:
● Print "<" if the date of the first build number is lower than the second one;
● Print "=" if the date of the first build number is same as he second one;
● Print ">" if the date of the first build number is higher than the second one.

If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.
 

Sample Input
  
  
2 FRF85B EPF21B KTU84L KTU84M
 

Sample Output
  
  
Case 1: > > Case 2: = <
 

Source
 

比较Android版本号,题意比较难搞清,If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version. 注意这句话。


#include <iostream>
#include <cstdio>
using namespace std;

const int MAXN = 10;
int nCase, cnt;
char A[MAXN], B[MAXN];

char judge() {
    for (int i = 2; i <= 4; i++) {
        if (A[i] != B[i]) {
            return A[i] < B[i] ? '<' : '>';
        }
    }
    if (A[1] == B[1]) {
        char a = (A[5] == '\0' ? 'A' : A[5]);
        char b = (B[5] == '\0' ? 'A' : B[5]);
        return (a == b ? '=' : (a < b ? '<' : '>'));
    }
    return '=';
}

int main() {
    scanf("%d", &nCase);
    while (nCase--) {
        scanf("%s%s", A, B);
        char ch1 = (A[0] == B[0] ? '=' : (A[0] < B[0] ? '<' : '>'));
        char ch2 = judge();
        printf("Case %d: %c %c\n", ++cnt, ch1, ch2);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值