Comparison of Android versions

 

As an Android developer, itˇs really not easy to figure out a newer version of two kernels, because Android is updated so frequently and has many branches. Fortunately, Google identifies individual builds with a short build code, e.g. FRF85B. 

The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat). 
The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch. 

The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010. 

Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity. 

Please develop a program to compare two Android build numbers.

InputThe first line is an integer n (1 <= n <= 2000), which indicates how many test cases need to process. 

Each test case consists of a single line containing two build numbers, separated by a space character.OutputFor each test case, output a single line starting with ¨Case #: 〃 (# means the number of the test case). Then, output the result of release comparison as follows: 

● Print "<" if the release of the first build number is lower than the second one; 
● Print "=" if the release of the first build number is same as he second one; 
 ● Print ">" if the release of the first build number is higher than the second one.

Continue to output the result of date comparison as follows: 
● Print "<" if the date of the first build number is lower than the second one; 
● Print "=" if the date of the first build number is same as he second one; 
● Print ">" if the date of the first build number is higher than the second one. 

If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.Sample Input

2
FRF85B EPF21B
KTU84L KTU84M

Sample Output

Case 1: > >
Case 2: = <

 

题意:先比较第一个字母的大小,输出一个符号,比较第二个,要是相等就比较后4个,不相等就比较接下来的3个

 

#include <stdio.h>
#include <string.h>
int main()
{
    char s1[7],s2[7],b[5],d[5];
    int i,n,j;
    scanf("%d",&n);
    getchar();
    for(i=1;i<=n;i++)
    {
        memset(b,0,sizeof(b));
        memset(d,0,sizeof(d));
        memset(s1,0,sizeof(s1));
        memset(s2,0,sizeof(s2));
        scanf("%s %s",&s1,&s2);
        printf("Case %d: ",i);
        if(s1[0]==s2[0])
            printf("= ");
        else
        if(s1[0]>s2[0])
           printf("> ");
        else
        if(s1[0]<s2[0])
           printf("< ");
        int k=0;
        if(s1[1]!=s2[1])
        {
            for(j=2;j<=4;j++)
                b[k++]=s1[j];
            b[k]=0;
            k=0;
            for(j=2;j<=4;j++)
                d[k++]=s2[j];
            d[k]=0;
        }
        else
        {
            for(j=2;j<=5;j++)
                b[k++]=s1[j];
            b[k]=0;
            k=0;
            for(j=2;j<=5;j++)
                d[k++]=s2[j];
            d[k]=0;
        }
        if(strcmp(b,d)==0)
            printf("=");
        else
        if(strcmp(b,d)>0)
           printf(">");
        else
        if(strcmp(b,d)<0)
           printf("<");
        puts("");
    }
    return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值